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Certification
Agilent Technologies certifies that this product met its published
specifications at the time of shipment. Agilent further certifies that its
calibration measurements are traceable to the United States National
Institute of Standards and Technology (formerly National Bureau of
Standards), to the extent allowed by that organization calibration facility,
and to the calibration facilities of other International Standards 
Organization members.

General Warranty
The material contained in this document is provided “as is,” and is subject 
to being changed, without notice, in future editions. Further, to the 
maximum extent permitted by applicable law, Agilent disclaims all 
warranties, either express or implied with regard to this manual and any 
information contained herein, including but not limited to the implied 
warranties of merchantability and fitness for a particular purpose. Agilent 
shall not be liable for errors or for incidental or consequential damages in 
connection with the furnishing, use, or performance of this document or 
any information contained herein. Should Agilent and the user have a 
separate written agreement with warranty terms covering the material in 
this document that conflict with these terms, the warranty terms in the 
separate agreement shall control. Duration and conditions of warranty for 
this product may be superseded when the product is integrated into 
(becomes a part of) other Agilent products. During the warranty period, 
Agilent will, at its option, either repair or replace products which prove to 
be defective. The warranty period begins on the date of delivery or on the 
date of installation if installed by Agilent.

Warranty Service
For warranty service or repair, this product must be returned to a service 
facility designated by Agilent. For products returned to Agilent for 
warranty service, the Buyer shall prepay shipping charges to Agilent and 
Agilent shall pay shipping charges to return the product to the Buyer. 
However, the Buyer shall pay all shipping charges, duties, and taxes for 
products returned to Agilent from another country.
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Limitation of Warranty
The foregoing warranty shall not apply to defects resulting from improper 
or inadequate maintenance by the Buyer, Buyer-supplied products or 
interfacing, unauthorized modification or misuse, operation outside of the 
environmental specifications for the product, or improper site preparation 
or maintenance.

The design and implementation of any circuit on this product is the sole 
responsibility of the Buyer. Agilent does not warrant the Buyer’s circuitry 
or malfunctions of Agilent products that result from the Buyer’s circuitry. 
In addition, Agilent does not warrant any damage that occurs as a result of 
the Buyer’s circuit or any defects that result from Buyer-supplied products.

To the extent allowed by local law, Agilent makes no other warranty, 
expressed or implied, whether written or oral with respect to this product 
and specifically disclaims any implied warranty or condition of 
merchantability, fitness for a particular purpose, or satisfactory quality.

Exclusive Remedies
To the extent allowed by local law, the remedies provided herein are the 
Buyer’s sole and exclusive remedies. Agilent shall not be liable for any 
direct, indirect, special, incidental, or consequential damages (including 
lost profit or data), whether based on warranty, contract, tort, or any other 
legal theory.
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Safety Summary
The following general safety precautions must be observed during all 
phases of operation of this instrument. Failure to comply with these 
precautions or with specific warnings elsewhere in this manual violates 
safety standards of design, manufacture, and intended use of the 
instrument. Agilent Technologies, Inc. assumes no liability for the 
customer’s failure to comply with these requirements.

Safety Notices

WARNING A WARNING notice denotes a hazard. It calls attention to an operating 
procedure, practice, or the like that, if not correctly performed or 
adhered to, could result in personal injury or loss of life. Do not proceed 
beyond a WARNING notice until the indicated conditions are fully 
understood and met.

CAUTION A CAUTION notice denotes a hazard. It calls attention to an operating 
procedure, practice, or the like that, if not correctly performed or adhered 
to, could result in damage to the product or loss of important data. Do not 
proceed beyond a CAUTION notice until the indicated conditions are fully 
understood and met.
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Safety Symbols
The following symbols on the instrument and in the documentation 
indicate precautions that must be taken to maintain safe operation of the 
instrument.

Caution, risk of danger (refer to this manual for specific Warning 
or Caution information)

Alternating current (AC)

Frame or chassis terminal
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General Safety Information
This is a Safety Class I instrument (provided with a protective earthing 
ground, incorporated in the power cord). The mains plug shall only be 
inserted in a socket outlet provided with a protective earth contact. Any 
interruption of the protective conductor inside or outside of the instrument 
is likely to damage the instrument. Intentional interruption is prohibited.

WARNING • Do not operate the instrument in an explosive atmosphere or in the 
presence of flammable gasses or fumes.

• Do not use repaired fuses or short-circuited fuseholders. For 
continued protection against fire, replace the line fuse(s) only with 
fuse(s) of the same voltage and current rating and type.

• Do not perform procedures involving cover or shield removal unless 
you are qualified to do so. Operating personnel must not remove the 
meter covers or shields. Procedures involving the removal of covers 
and shields are for use by service-trained personnel only.

• Do not service or adjust alone. Under certain conditions, dangerous 
voltages may exist even with the instrument switched off. To avoid 
electrical shock, service personnel must not attempt internal service 
or adjustment unless another person, capable of rendering first aid 
and resuscitation, is present.

• Do not operate damaged instrument. Whenever it is possible that the 
safety protection features built into this instrument have been 
impaired, either through physical damage, excessive moisture, or 
any other reason, REMOVE POWER and do not use the instrument 
until safe operation can be verified by service-trained personnel. If 
necessary, return the instrument to Agilent for service and repair to 
ensure the safety features are maintained.

• Do not substitute parts or modify the instrument. Because of the 
danger of introducing additional hazards, do not install substitute 
parts or perform any unauthorized modification to the instrument. 
Return the instrument to Agilent for service and repair to ensure the 
safety features are maintained.
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Regulatory Markings

The CE mark is a registered trademark of the European Community. This CE 
mark shows that the product complies with all the relevant European Legal 
Directives.

The C-tick mark is a registered trademark of the Spectrum Management Agency 
of Australia. This signifies compliance with the Australian EMC Framework 
regulations under the terms of the Radio Communications Act of 1992.

ICES/NMB-001 indicates that this ISM device complies with the Canadian 
ICES-001. Cet appareil ISM est confomre à la norme NMB-001 du Canada.

This product complies with the WEEE Directive (2002/96/EC) marking 
equipment. The affixed product label indicates that you must not discard this 
electrical/electronic product in domestic household waste.

The CSA mark is a registered trademark of the Canadian Standards Association. 
A CSA mark indicates that the product is certified for Canadian markets, to the 
applicable Canadian standards.

This symbol indicates the time period during which no hazardous or toxic 
substance elements are expected to leak or deteriorate during normal use. Forty 
years is the expected useful life of the product.
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Waste Electrical and Electronic Equipment (WEEE) Directive 
2002/96/EC

This instrument complies with the WEEE Directive (2002/96/EC) marking 
requirement. This affixed product label indicates that you must not discard 
this electrical/electronic product in domestic household waste. 

Product Category:

With reference to the equipment types in the WEEE directive Annex 1, this 
instrument is classified as a “Monitoring and Control Instrument” product.

The affixed product label is shown as below.

Do not dispose in domestic household waste

To return this unwanted instrument, contact your nearest Agilent Service 
Center, or visit: 

www.agilent.com/environment/product

for more information.
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In This Guide...

1 Introduction

This chapter provides a general overview of the Agilent 8990B Peak Power 
Analyzer which includes descriptions of its outlook and Web interface.

2 Using the 8990B

This chapter provides the information on the 8990B general operation.

3 Maintenance

This chapter describes the built-in self-tests, error messages, and general 
maintenance of the 8990B.

4 Characteristics and Specifications

This chapter lists the characteristics and specifications of the 8990B.
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Declaration of Conformity (DoC)
The Declaration of Conformity (DoC) for this instrument is available on the 
Agilent Web site. You can search the DoC by its product model or 
description at the Web address below.

http://regulations.corporate.agilent.com/DoC/search.htm

NOTE If you are unable to search for the respective DoC, please contact your 
local Agilent representative.
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This chapter provides a general overview of the 8990B peak power 
analyzer.
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Overview of the 8990B

The 8990B is a peak power analyzer that consists of two RF input 
channels (1 and 4) and two video input channels (2 and 3). When used 
with a compatible wideband power sensor, the 8990B is able to measure 
the dynamic or time- dependent aspects of RF and microwave power. A 
combination of the 8990B and the N1923/4A wideband power sensor 
enables the RF pulse rise/fall time measurement of up to 5 ns. The video 
inputs of the 8990B allow the simultaneous analysis of time- domain 
control signals. 

The 8990B has a frequency range of 50 MHz to 40 GHz and a dynamic 
power range of –35 dBm to 20 dBm, depending on the wideband power 
sensor used. The 8990B is capable of measuring peak power, minimum 
power, average power, peak- to- average power, pulse repetition interval, 
pulse repetition rate, rise time, fall time, pulse off time, pulse top, pulse 
base, pulse width, duty cycle, and overshoot. The 8990B also provides 
internal and external trigger functions.
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Standard Shipped Items

Verify that you have received the following items with your 8990B. If 
anything is missing or damaged, contact the nearest Agilent Sales Office.

• 8990B peak power analyzer

• Power cord

• Optical mouse

• Mini keyboard

• Stylus pen

• Two units of 50 Ohm BNC cable

• Agilent 8990B Peak Power Analyzer User’s Guide, English[1]

• Agilent 8990B Peak Power Analyzer Installation Guide, English[1]

• Agilent 8990B Peak Power Analyzer Product Reference CD- ROM

• Agilent IO Libraries Suite CD- ROM

• Certificate of Calibration

Standard 8990B options

• Standard hard drive installed (Option 800)[2]

• Removable hard drive installed (Option 801)[2]

• 8990B with USB host connectivity (Option U01)[3]

• 8990B without USB host connectivity (Option U02)[3]

[1] Only applicable when the default manual configuration, 8990B-ABA is selected.

[2] Select either Option 800 or Option 801

[3] Select either Option U01 or U02
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Optional Items

The following items are available for purchase separately.

• Rack mount kit (Option 1CM, 8U full rack)

• N6921A stacking kit

• N6922A BNC extension cable, male to female

• N6923A BNC adapter, right angle

• N6924A additional hard drive with image

• N6925A storage pouch

• 8990B Programming Guide, English (Option OBF, printed)

• 8990B User’s Guide, English and Programming Guide, English 
(Option OBK, printed)

• 8990B Service Guide, English (Option OBW, printed)

• 8990B User’s Guide, Japanese and Programming Guide, English 
(Option ABJ, printed)

• 8990B User’s Guide, English (Option ABA, printed)

• N1923A User’s Guide, Japanese (N1923A- ABJ, printed)

• N1923A User’s Guide, English (N1923A- OB1, printed)

• N1923A Service Guide, English (N1923A- OBN, printed)

• N1924A User’s Guide, Japanese (N1924A- ABJ, printed)

• N1924A User’s Guide, English (N1924A- OB1, printed)

• N1924A Service Guide, English (N1924A- OBN, printed)

• Return- to- Agilent Warranty and Service Plan

• Return- to- Agilent Calibration Plan

• ISO 17025 compliant calibration test data (Option 1A7, printed)

• ANSI/NCSL Z540 Certificate of Compliance Calibration (Option A6J, 
printed)

• Multipulse analysis software, fixed perpetual license (8990B- 1FP)

• Multipulse analysis software (N6903A)
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Sensor Compatibility

The 8990B is compatible with the Agilent N1923/4A wideband power 
sensor. A combination of the 8990B and the N1923/4A wideband power 
sensor enables the RF pulse rise or fall time measurement of up to 5 ns. 
The following table lists the frequency range and dynamic power range for 
each of these sensors:

The 8990B is also compatible with the Agilent N1921/2A P- Series 
wideband power sensor. The following table lists the frequency range and 
dynamic power range for each of these sensors:

Wideband power 
sensor model

Frequency range Rise/fall time Dynamic power range

N1923A 50 MHz to 18 GHz ≤5.5 ns[1] –35 dBm to +20 dBm

N1924A 50 MHz to 40 GHz ≤5.5 ns[1] –35 dBm to +20 dBm

[1] Applicable for frequency of ≥500 MHz.

P-Series wideband 
power sensor model

Frequency range Rise/fall time Dynamic power range

N1921A 50 MHz to 18 GHz ≤13 ns[1] • –35 dBm to +20 dBm (≥500 MHz)
• –30 dBm to +20 dBm (50 MHz to 500 MHz)

N1922A 50 MHz to 40 GHz ≤13 ns[1] • –35 dBm to +20 dBm (≥500 MHz)
• –30 dBm to +20 dBm (50 MHz to 500 MHz)

[1] Specification applies only when the Off video bandwidth is selected.

NOTE For further information on these sensors, refer to their respective manuals.
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Probe Compatibility

The 8990B is compatible with the Agilent N2873A passive probe which has 
a DC- to- 500 MHz frequency range and a 10:1 attenuation factor.

NOTE The 8990B video input channels are able to support passive probes with analog bandwidth 
of up to 1 GHz.
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Front Panel Outlook

This topic briefly describes the functions of the front panel keys, knobs, 
and connectors.

Figure 1-1 Front panel outlook

This section is associated with the power switch, probe compensation 
output, measurement channels, sensor check source, and USB ports.

Item Description

Power on/off Press this key to turn on or off the 8990B

RF input 
channels 

Connect to the RF input using the N1921/2/3/4A 
wideband power sensors
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Figure 1-2 Run Control section

This section is categorized as run controls.

Video input 
channels 

Connect to the video input using the N2873A oscilloscope 
probes or N6922A BNC cable

Probe 
compensation 
output 

Performs adjustment of the probe capacitor in order to 
maximize the bandwidth of the probe.

NOTE: Probe compensation will only be supported in future 
releases.

Sensor check 
source 

Sensor check source for sensor that outputs an RF carrier 
of 1.05 GHz with a modulating pulse train signal of 
1 kHz from a Type-N female connector. 
The RF level is 0 dBm at the carrier frequency.

USB Hosts
Connect to external USB devices. You can connect or 
disconnect the external USB devices without shutting 
down or restarting the 8990B.

Item Description

Press this key to start or stop a continuous data acquisition

Press this key to make a single data acquisition when the next trigger event 
occurs

Item Description
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Figure 1-3 Horizontal section

This section is associated with horizontal controls as well as zoom, 
autoscale, touch screen, clear display, and default setup functions.

Item Description

Turn this knob to configure the horizontal scale of the display. 

NOTE: Vernier function (fine scaling) will only be supported in future releases.

Press this key to view a magnified section of the waveform

Turn this knob to configure the horizontal position of the waveform. Push this 
knob to set the horizontal position to zero.

Press this key to automatically scale the waveform to the optimized display

Press this key to enable or disable the touch screen

Press this key to clear the waveform display. When the 8990B is running in the 
continuous acquisition mode, this function will clear the current waveform and 
redraw it. 

Other than the waveform, this function also clears the data for measurements, 
markers, droop, and averaging.

Press this key to return the 8990B to the factory default settings
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Figure 1-4 Trigger section

This section is categorized as trigger controls.

Item Description

Press this key to set the trigger source to any of the channels or auxiliary. 
The selected trigger source LED above this key will be illuminated.

Press this key to trigger on a rising or falling edge. The selected slope LED 
above this key will be illuminated.

Press this key to set the trigger sweep mode to either automatic or triggered. 
The selected sweep mode LED above this key will be illuminated.

Press this key to access the trigger menu

Turn this knob to configure the trigger level. Push this knob to set the trigger 
level to 50%. 
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Figure 1-5 Measure section

This section is categorized as measurement and marker controls.

Item Description

Turn this knob to change the position of the marker. Push this knob to select a 
marker or toggle between two markers.

Press this key to access the marker selection dialog
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Figure 1-6 Vertical section

This section is categorized as vertical controls. 

This section has a set of LEDs per channel that indicate the input 
impedance, coupling, and whether or not bandwidth limit is enabled for 
the channel.

Item Description

Turn the knob for a particular channel to configure the vertical scale of the 
display. 

NOTE: Vernier function (fine scaling) will only be supported in future releases.

Press this key to turn the display on or off for a particular channel

Turn the knob for a particular channel to configure the vertical offset of the 
waveform
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Side Panel Outlook

The following connectors and hard drive are available on the side panel. 
To set up the remote interfaces, refer to the 8990B Installation Guide.

Figure 1-7 Side panel outlook

No. Item Description

1 Keyboard PS/2 port Allows a keyboard to be plugged in to control the 8990B 
graphical interface. 

The keyboard must be plugged in prior to turning on the 8990B.

2 Mouse PS/2 port Allows a mouse to be plugged in to control the 8990B graphical 
interface. 

The mouse must be plugged in prior to turning on the 8990B. 

3 Serial printer port Allows a serial printer to be connected to the 8990B

1
2

3
4

5

6

7

9
10
11
12

13

8
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4 XGA video output Allows an external monitor to be connected to the 8990B

5 DVI video output Allows an external monitor to be connected to the 8990B

6 Removable hard drive Allows the 8990B hard drive to be swapped with another 
hard drive

7 USB ports Allows external USB devices to be connected to the 8990B. 

You can connect or disconnect the external USB devices without 
shutting down or restarting the 8990B.

8 LAN port Allows the 8990B to be controlled remotely over the LAN 
interface

9 Microphone port Allows a microphone to be connected to the 8990B

10 Audio line-in port Allows an external audio device to be connected to the 8990B

11 Headphone sound 
output port

Allows a headphone to be connected to the 8990B

12 USB Type-B port Allows the 8990B to be controlled remotely over the USB 
interface

13 AC power inlet Allows the 8990B to be connected to an AC line voltage

No. Item Description
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Rear Panel Outlook

The following connectors are available on the rear panel.

Figure 1-8 Rear panel outlook

No. Item Description

1 Auxiliary trigger out Used to provide internal 8990B waveforms for calibration and 
external triggering 

2 10 MHz reference in Used to synchronize the 8990B horizontal timebase system to 
a reference clock that you provide. The clock that you provide 
must meet the following specifications:

Level: –2 dBm to 10 dBm

Impedance: 50 Ω

1

2

3

4

5
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3 10 MHz reference out Used to track the external reference input level. The output 
specifications are as follows:

Level: 4 dBm to ±2 dBm

Impedance: 50 Ω 

4 Auxiliary trigger in Used as a trigger source for rising edge TTL level triggering 
only. The input specifications are as follows:

Level: ±5 V

Impedance: 50 Ω 

5 Trigger out Used to provide TTL compatible logic levels with an output 
impedance of 50 Ω for external triggering

No. Item Description
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Display Outlook

The graphical interface provides access to the configuration and 
measurement features of the 8990B through an easy- to- use system of 
menus, toolbars, dialog boxes, icons, and buttons. You can control the 
graphical interface using the touch screen feature, via connected 
peripherals such as a mouse or a keyboard, or using the front panel 
interface (where applicable). 

The following section provides a general overview of the graphical 
interface layout.

Figure 1-9 Display outlook

1
2

4

5

6

7

8

3



1 Introduction

18 8990B User’s Guide

Table 1-1 Display outlook description

No. Description

1 This is the toolbar which provides access to file management, instrument settings, 
measurement controls, and help information

2 This is the channel vertical scale control field which allows you to turn on or off the 
channel, configure the channel settings, and adjust the vertical scale of the display 

3 This is the measurement menu which enables you to select and perform the 
measurements available. The >> and << buttons at the bottom of the menu provide 
access to the next and previous lists of measurements respectively. 

4 This is the acquisition control field which enables you to start or stop a continuous data 
acquisition or perform a single data acquisition of the waveform. You can also log and save 
the measurement data.

5 This is the trigger menu which allows you to configure the trigger settings

6 This is the horizontal (time) scale control and marker field which allows you to configure 
the timebase settings and select the A and B markers to apply on the trace

7 This is the display control field which allows you to clear the display and  perform 
averaging and autoscaling on the waveform 

8 This is the multi-purpose pane which enables you to select any of the seven types of 
views to display: status view, measurement view, marker view, X-Y position view, droop 
view, limit test view, and log view
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LCD display layout

Figure 1-10 LCD display layout

Marker B label

Trigger line 
marker

Marker A label

Channel 1 
level marker

Channel 2 
level marker

Channel 3 
level marker

Channel 4 
level marker
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Hiding the Side Menus and Multi-Purpose Pane

The 8990B allows you to hide the measurement menu, trigger menu, and 
multi- purpose pane.

1 Select the pin button to hide the menus or multi- purpose pane.

Figure 2-1  Pin button

2 The display outlook with the hidden menus and multi- purpose pane is 
as shown in Figure 2- 2.

Figure 2-2  Display outlook with hidden menus and multi-purpose pane.



2 Operating Information

24 8990B User’s Guide

Enabling or Disabling the Touch Screen

The 8990B allows you to navigate the graphical interface via touch screen. 
The touch screen capability is enabled by default.

Use the following procedure to enable or disable the touch screen.

1 To enable or disable the touch screen capability, press  in the 
Horizontal section of the front panel as shown in Figure 2- 3.

Figure 2-3  Touch button in the Horizontal section

2 The  LED illuminates white when the touch screen capability is 
enabled.
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Accessing the Toolbar Menus

The toolbar is located at the top of the graphical interface as shown in 
Figure 2- 4.

Figure 2-4  Toolbar on the graphical interface

Select the desired toolbar title to display the drop- down menu. Select an 
item from the drop- down menu to execute its respective function. The 
description for each drop- down menu on the toolbar is shown in 
Table 2- 1.

Table 2-1 Toolbar menus

Level 1 menu Level 2 menu Description

File Load Waveform... Load the saved waveform. Refer to “Saving and Loading Waveform 
Memories” on page 61 for more information.

Save Waveform... Save the current waveform data. The waveform data is saved as a CSV 
file. Refer to “Saving and Loading Waveform Memories” on page 61 for 
more information.

Save Screen... Save the current graphical interface screen. Refer to “Saving the 
Screen” on page 128 for more information.

Save Screen (Printer 
Friendly)

Save the current graphical interface screen in black and white. Refer to 
“Saving the Screen” on page 128 for more information.

Restore Saved Setup... Restore a saved 8990B state. Refer to “Saving and Restoring 8990B 
States” on page 129 for more information.

Save Current Setup... Save the current 8990B state. Refer to “Saving and Restoring 8990B 
States” on page 129 for more information.

Restore Default Setup Reset the 8990B to the factory default settings. Refer to “Restoring the 
8990B to Factory Default Settings” on page 137 for more information.
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Save Report... Generate and save a report. Refer to “Generating and Saving a 
Report” on page 133 for more information.

Exit Exit the 8990B graphical interface

Acquisition Run Start waveform acquisition. Refer to “Starting and Stopping Waveform 
Acquisition” on page 43 for more information.

Stop Stop waveform acquisition. Refer to “Starting and Stopping Waveform 
Acquisition” on page 43 for more information.

Clear Display Clear the waveform display, measurement data, marker information, 
droop measurement data, and waveform averaging. Refer to “Clearing 
the Waveform Display” on page 46 for more information.

Zoom Magnify a section of the waveform. Refer to “Magnifying a Section of 
the Waveform Using Zoom” on page 85 for more information.

CCDF Display the Complementary Cumulative Distribution Function (CCDF) 
information for the RF input channels. Refer to “Displaying the 
Complementary Cumulative Distribution Function (CCDF) 
Information” on page 90 for more information.

Split screen Split the waveform screen to four separate channel screens. Refer to 
“Splitting the Waveform Screen” on page 88 for more information.

MultiPulse Access the multipulse mode. Refer to “Accessing the Multipulse 
Mode” on page 97 for more information.

Display XY Display the XY Display mode. Refer to “Accessing the Display XY 
Mode” on page 104 for more information.

Auto-Scale Scale the waveforms to the optimized display. Refer to “Enabling 
Autoscale” on page 52 for more information.

Undo Autoscale Undo the autoscaling. Refer to “Enabling Autoscale” on page 52 for 
more information.

Save measurement... Log and save the measurements data. Refer to “Logging and Saving the 
Measurement Data” on page 131 for more information.

Setup Channel 1... Configure the channel 1 settings. Refer to “Accessing the Channel 
Setup” on page 31 for more information.

Channel 2... Configure the channel 2 settings. Refer to “Accessing the Channel 
Setup” on page 31 for more information.

Table 2-1 Toolbar menus (continued)

Level 1 menu Level 2 menu Description
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Channel 3... Configure the channel 3 settings. Refer to “Accessing the Channel 
Setup” on page 31 for more information.

Channel 4... Configure the channel 4 settings. Refer to “Accessing the Channel 
Setup” on page 31 for more information.

Trigger... Configure the trigger settings. Refer to “Accessing the Trigger Setup” on 
page 54 for more information.

Acquisition... Configure the ETS acquisition setup. Refer to “Equivalent Time Sampling 
(ETS)” on page 47 for more information.

Display Setup Configure the display settings. Refer to “Configuring the Display 
Settings” on page 140 for more information.

Measurement Thresholds Configure the measurement threshold settings. Refer to “Setting the 
Measurement Threshold” on page 58 for more information.

Waveform Memory Load multiple saved waveform files. You can select a saved waveform to 
enable and adjust the horizontal scale and offset. Refer to “Saving and 
Loading Waveform Memories” on page 61 for more information.

Waveform Math Perform waveform math operations on a pair of RF input or video input 
channels. Refer to “Performing Waveform Math Operations” on page 65 
for more information.

Measure Measurement functions Select the desired measurement functions to measure. Refer to 
“Measurement view” on page 108 for more information.

Tools Front Panel Test... Verify the 8990B front panel keys and knobs. Refer to “Front Panel 
Test” on page 144 for more information.

Limit Test... Set the upper limit and lower limit values, and track the values. Refer to 
“Limit test view” on page 120 for more information.

Self Test... Perform instrument self-test on the 8990B. Refer to “Front Panel 
Test” on page 144 for more information.

Remote Setup... Display the 8990B remote setup parameters. Refer to “Remote 
Setup” on page 142 for more information.

Auto Cal... Configure the sensor auto-calibration settings. Refer to “Performing 
Zeroing and Calibration” on page 123 for more information.

Check Source Configure the sensor check source settings. Refer to “Sensor Check 
Source” on page 126 for more information.

Table 2-1 Toolbar menus (continued)

Level 1 menu Level 2 menu Description
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Secure Erase... Erase the 8990B setup, FDO tables, and reference memory. Refer to 
“Secure Erase” on page 136 for more information.

Toggle 10 MHz Input Enable or disable the 10 MHz reference input for the video input 
channels. When the 10 MHz reference input is enabled, the 10MHz 
Input status is displayed in the Status view. Refer to “Status view” on 
page 107 for more information.

FDO Set the Frequency-Dependent Offset (FDO) for different frequency 
points. Refer to “Setting the Frequency-Dependent Offset (FDO)” on 
page 82 for more information.

Marker Track the X-axis and Y-axis values, and the delta values between the two 
markers. Refer to “Marker view” on page 110 for more information.

Support Documentation Display the 8990B documentation information

Help Display the 8990B help information

Tutorial Video Display the 8990B tutorial video

About Display the 8990B product information

License Display the installed licenses in the 8990B

Table 2-1 Toolbar menus (continued)

Level 1 menu Level 2 menu Description
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Turning Channels On or Off

Channel 1 to channel 4 in the 8990B are color- coded in yellow, green, 
blue, and red respectively. Turn off the channels that you are not using to 
simplify the waveform display and increase the display refresh rate. The 
8990B channels can be turned on from the Vertical section on the front 
panel or the graphical interface.

Use the following procedures to turn on or off the channels.

Front panel

1 Press the desired channel number button in the Vertical section to turn 
on the channel as shown in Figure 2- 5.

Figure 2-5  Channel number buttons in the Vertical section

NOTE For RF input channel 1 and 4, the channels can only be turned on when a wideband power 
sensor is connected.

Channel 1

Channel 2 

Channel 3 

Channel 4 
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2 The channel number button LED illuminates when it is turned on.

3 Press the channel number button again to turn off the channel.

Graphical interface

1 Select the desired channel number button on the graphical interface to 
turn on the channel as shown in Figure 2- 6.

Figure 2-6  Channel number button on the graphical interface

2 The channel number button darkens when it is turned on.

3 Select the channel number button again to turn off the channel.

NOTE The channels can also be turned on or off from the Channel Setup dialog. For more 
information on the Channel Setup dialog, refer to “Accessing the Channel Setup” on 
page 31.
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Accessing the Channel Setup

The Channel Setup dialog allows you to configure the settings for each 
channel. 

For RF input channels, you can turn on or off the channel, and set the 
power display type, vertical scale, frequency, reference style, reference 
level, external loss, bandwidth, and perform zeroing and calibration of the 
sensor from the Channel Setup dialog. 

For video input channels, you can turn on or off the channel, and set the 
vertical scale and offset, input coupling, input impedance, and probe 
attenuation ratio. 

You can select the channel number button at the top of the Channel Setup 
dialog to access the setup for the desired channel.

Use the following procedure to access the channel setup.

1 Select the vertical scale area for the desired channel on the graphical 
interface as shown in Figure 2- 7.

Figure 2-7  Vertical scale area on the graphical interface
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2 For the RF input channel, the Channel Setup dialog is displayed as 
shown in Figure 2- 8.

Figure 2-8  RF input Channel Setup dialog

Power Display

Select either Log or Linear as the power display type for the RF input 
channel signal.

Scale

Set the vertical scale value for the RF input channel. Refer to “Adjusting 
the Vertical Scale and Offset” on page 36 for more information.

Frequency

Setting the frequency of the RF input channel signal. This will optimize 
the accuracy and minimize the measurement uncertainty, especially when 
making comparative measurements between signals.
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Ref Style

Select among TOP, CENTER, or BOTTOM as the reference style.

Reference Level

Set the reference level value for the RF input channel. Refer to “Adjusting 
the Vertical Scale and Offset” on page 36 for more information.

Ext Loss

Set the external loss for the RF input channel signal caused by a coupler, 
amplifier, or cable.

Bandwidth

Select among OFF, LOW, MEDIUM, or HIGH for the bandwidth. The 
bandwidth set will minimize the effect of any visible noise in the signal.

Time Comp

Set the time compensation value for the RF input channel. The time 
compensation set will overcome any timing delay in the cable. The step 
size for the time compensation increment (>) and decrement (<) buttons 
is set to a time scale of 1/500.

Zero & Cal, Cal, and Zero

Perform zeroing and calibration on the connected power sensor. Refer to 
“Performing Zeroing and Calibration” on page 123 for more information.
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3 For the video input channel, the Channel Setup dialog is displayed as 
shown in Figure 2- 9.

Figure 2-9  Video input Channel Setup dialog

Scale

Set the vertical scale value for the video input channel. Refer to “Adjusting 
the Vertical Scale and Offset” on page 36 for more information.

Offset 

Set the vertical offset value for the video input channel. Refer to 
“Adjusting the Vertical Scale and Offset” on page 36 for more information.

Coupling

Select either DC or AC coupling for the video input channel signal.
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Input

Select either 50 Ω or 1 MΩ as the input impedance for the video input 
channel signal.

Probe

View the probe information used at the video channel.

Time Comp

Set the time compensation value for the video input channel. The time 
compensation set will overcome any timing delay in the cable.

4 After you have completed the channel setup, select the close button at 
top right corner of the dialog or select Close to close the Channel Setup 
dialog.
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Adjusting the Vertical Scale and Offset

Adjusting the vertical scale increases or decreases the number of watts 
per division (W/div) or decibels per division (dB/div) for RF input 
channels and the number of volts per division (V/div) for video input 
channels. Adjusting the vertical offset moves the waveform towards the 
top or bottom of the display. The vertical scale and offset can be adjusted 
from the Vertical section on the front panel or the graphical interface.

Use the following procedures to adjust the vertical scale and offset.

Front panel

1 To adjust the vertical scale, turn the vertical scale knob of the desired 
channel in the Vertical section as shown in Figure 2- 10.

Figure 2-10  Vertical scale and offset knobs in the Vertical section

2 Turn the vertical scale knob clockwise to decrease the vertical scale 
value or counter- clockwise to increase the vertical scale value.

3 To adjust the vertical offset, turn the vertical offset knob of the desired 
channel in the Vertical section as shown in Figure 2- 10.

4 Turn the vertical offset knob clockwise to move the waveform towards 
the top of the display or counter- clockwise to move the waveform 
towards the bottom of the display.

Vertical offset 
knobs

Vertical scale 
knobs
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Graphical interface

1 Select the vertical scale area of the desired channel at the top of the 
graphical interface to access the Channel Setup dialog as shown in 
Figure 2- 7.

2 For RF input channels, select the vertical scale field on the Channel 
Setup dialog to adjust the vertical scale as shown in Figure 2- 11.

Figure 2-11  Vertical scale and reference level field for the RF input channel

3 The vertical offset in the RF input channel is referred to as top 
reference level, center reference level, or bottom reference level 
depending on the desired reference style. Select the reference level field 
on the Channel Setup dialog to adjust the reference level as shown in 
Figure 2- 11.

4 For video input channels, select the vertical scale field on the Channel 
Setup dialog to adjust the vertical scale as shown in Figure 2- 12.

Vertical scale field

Reference level field
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Figure 2-12  Vertical scale and offset field for the video input channel

5 Select the vertical offset field on the Channel Setup dialog to adjust the 
vertical offset as shown in Figure 2- 12.

6 The vertical scale keypad dialogs are displayed as shown in Figure 2- 13.

Figure 2-13  Vertical scale keypad dialogs

7 Set the desired value and select OK to confirm.

Vertical scale field

Vertical offset field
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8 You can also adjust the vertical scale using + and – as shown in 
Figure 2- 14.

Figure 2-14  Vertical scale adjustment on the graphical interface

9 The reference level keypad dialog for the RF input channel is displayed 
as shown in Figure 2- 15.

Figure 2-15  Reference level keypad dialog for the RF input channel

10 The vertical offset keypad dialog for the video input channel is 
displayed as shown in Figure 2- 16.

Figure 2-16  Vertical offset keypad dialog for the video input channel

11 Set the desired value and select OK to confirm.
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Adjusting the Horizontal Scale and Offset

Adjusting the horizontal scale increases or decreases the number of 
seconds per division (s/div). Adjusting the horizontal offset moves the 
waveform towards the left or right of the display. The horizontal scale and 
offset can be adjusted from the Horizontal section on the front panel or 
the graphical interface.

Use the following procedures to adjust the horizontal scale and offset.

Front panel

1 To adjust the horizontal scale, turn  in the Horizontal section as 
shown in Figure 2- 17.

2 Turn  clockwise to decrease the horizontal scale value or 
counter- clockwise to increase the horizontal scale.

3 To adjust the horizontal offset, turn  in the Horizontal section as 
shown in Figure 2- 17.

4 Turn  clockwise to move the waveform towards the right of the 
display or counter- clockwise to move the waveform towards the left of 
the display.

Figure 2-17  Horizontal scale and offset knobs in the Horizontal section

5 To set the offset to zero, push .

NOTE Negative horizontal offset will reduce the sampling rate and cause trace distortion. It is 
recommended to set the offset relatively close to the horizontal scale for optimum 
performance.

Horizontal 
offset knob

Horizontal 
scale knob
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Graphical interface

1 To adjust the horizontal scale, select the horizontal scale area on the 
graphical interface as shown in Figure 2- 18.

Figure 2-18  Horizontal scale on the graphical interface

2 The horizontal scale keypad dialog is displayed as shown in 
Figure 2- 19.

Figure 2-19  Horizontal scale keypad dialog

3 Set the desired value and select OK to confirm.

4 You can also adjust the horizontal scale using + and – as shown in 
Figure 2- 18.

5 To adjust the horizontal offset, select the horizontal offset area on the 
graphical interface as shown in Figure 2- 20.

NOTE The horizontal scale knob is adjustable in factors of 1, 2, and 5.
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Figure 2-20  Horizontal offset on the graphical interface

6 The horizontal offset keypad dialog is displayed as shown in 
Figure 2- 21.

Figure 2-21  Horizontal offset keypad dialog

7 Set the desired value and select OK to confirm.

8 You can also adjust the horizontal offset using << and >>, or set the 
offset to zero using 0 as shown in Figure 2- 20.

NOTE The step size for the horizontal offset buttons is set to a time scale of 1/50.
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Starting and Stopping Waveform Acquisition

The 8990B allows you to perform a continuous or single data acquisition 
of the waveform from the Run Control section on the front panel or the 
graphical interface.

Continuous waveform acquisition

Use the following procedures to perform continuous waveform acquisition.

Front panel

1 Press  in the Run Control section as shown in Figure 2- 22 to 
start a continuous data acquisition of the waveform.

Figure 2-22  Run/Stop button in the Run Control section

2 The  LED illuminates green when the continuous data acquisition 
is running.

3 To stop the continuous data acquisition, press  again in the Run 

Control section. The  LED illuminates red when the acquisition is 
stopped.
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Graphical interface

1 Select the start or stop button on the bottom left of the graphical 
interface to start or stop a continuous data acquisition of the waveform 
respectively as shown in Figure 2- 23.

Figure 2-23  Start and stop buttons on the graphical interface

2 The start or stop button is grayed out when you start or stop the 
continuous waveform acquisition respectively.

Single waveform acquisition

Use the following procedures to perform single waveform acquisition.

Front panel

1 Press  in the Run Control section as shown in Figure 2- 24 to 
perform a single data acquisition of the waveform.

Figure 2-24  Single waveform acquisition button in the Run Control section

2 The  LED illuminates yellow when the single data acquisition is 
running.

Stop 
button

Start 
button
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Graphical interface

Select the Single button on the bottom left of the graphical interface to 
perform a single data acquisition of the waveform as shown in 
Figure 2- 25.

Figure 2-25  Single waveform acquisition button on the graphical interface

Single button
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Clearing the Waveform Display

Clearing the waveform display will clear the measurement data, marker 
information, droop measurement data, and waveform averaging. The 8990B 
allows you to clear the waveform display from the Horizontal section on 
the front panel or the graphical interface.

Use the following procedures to clear the waveform display.

Front panel

Press  in the Horizontal section to clear the waveform display as 
shown in Figure 2- 26.

Figure 2-26  Clear Display button in the Horizontal section

Graphical interface

Select Clear on the bottom right of the graphical interface to clear the 
waveform display as shown in Figure 2- 27.

Figure 2-27  Clear button on the graphical interface

NOTE • When the 8990B is running in a continuous acquisition mode, the Clear Display function 
clears the current waveform and redraws it. 

• Waveform memory will not be cleared when the Clear Display function is used.
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Equivalent Time Sampling (ETS)

The ETS function in the 8990B is used to increase the effective sampling 
rate for high bandwidth repetitive signals detection. ETS is implemented 
by accumulating the samples of the input signals at slightly different 
starting points and accumulating them over several cycles to construct a 
complete waveform trace line.

The ETS function auto- ETS is enabled by default. You can enable or 
disable auto- ETS from the Acquisition Setup dialog. When auto- ETS is 
enabled, the ETS function is automatically turned on when the horizontal 
scale is less than the ETS threshold. The ETS threshold can be set to 
500 ns, 1 μs, 2 μs, 5 μs, or 10 μs. The default ETS threshold is 500 ns. 
When auto- ETS is disabled, the ETS function will not be turned on at all. 

Use the following procedure to enable the auto- ETS function.

1 Select Setup > Acquisitions... on the toolbar as shown in Figure 2- 28.

Figure 2-28  Acquisition selection in the Setup menu
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2 The Acquisition Setup dialog is displayed as shown in Figure 2- 29. 
Select the Auto check box to enable the auto- ETS feature and select the 
desired ETS threshold. Select the (Sin x)/x Interpolation check box to 
allow 1 GHz analog bandwidth verification.

Figure 2-29  Acquisition Setup dialog

3 The ETS status is displayed in the Status view as shown in Figure 2- 30. 
For more information on the Status view, refer to “Status view” on 
page 107.

Figure 2-30  ETS status in the status view

For a complete waveform trace, use continuous waveform acquisition. 
When single waveform acquisition is used, the waveform trace will not be 
drawn as the ETS function trace is not completeled. Press  
continuously to allow the ETS function to complete the trace. 

For more information on the continuous and single waveform acquisition, 
refer to “Starting and Stopping Waveform Acquisition” on page 43.
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When the ETS function is acquiring data to complete the waveform trace, 
the ETS status is displayed as shown in Figure 2- 31.

Figure 2-31  ETS acquiring data status in the status view

NOTE The ETS function is not supported in Auto trigger mode. Trigger mode will be set to 
Triggered when ETS is enabled.

NOTE When the ETS function is enabled, the allowable horizontal offset settings is limited, 
depending on the timebase settings. This limitation is to avoid any under-sampling 
situation that will cause trace distortion.
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Setting the Averaging

Averaging uses a digital filter to average repetitions of a triggered signal. 
The average of a number of acquisitions is calculated to smoothen the 
displayed trace and reduce apparent noise. 

The averaging counts can be in a range of 2 to 2048, in multiples of 2n. 
Increasing the value of a measurement average count reduces the noise 
but increases the time required to make the measurement. The averaging 
count values are predefined to 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, and 
2048.

Use the following procedure to set the averaging.

1 Select Avg on the bottom right of the graphical interface to enable the 
waveform averaging as shown in Figure 2- 32.

Figure 2-32  Averaging button on the graphical interface

2 The Averaging dialog is displayed as shown in Figure 2- 33.

Figure 2-33  Averaging dialog

3 Select the Enable check box to turn on the averaging.

4 To change the average count, select the Count field on the Averaging 
dialog to display the count selection as shown in Figure 2- 34.

NOTE If averaging is turned on in the ETS mode, averaging will only be performed after the ETS 
operation is completed.
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Figure 2-34  Averaging count selection on the Averaging dialog

5 Select the desired averaging count and select Close.

6 The waveform averaging status is displayed in the Status view as shown 
in Figure 2- 35.

Figure 2-35  Waveform averaging status in the status view

NOTE For more information on the Status view, refer to “Status view” on page 107.
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Enabling Autoscale

Autoscale feature evaluates all input signals and sets the correct 
conditions to best display the signals. The 8990B will automatically 
configure the X- axis and Y- axis values. For the X- axis, the horizontal 
scale is scaled with reference to the higher priority channel in the order 
of channel 4, 3, 2, and 1 respectively. 

A notification dialog is displayed when autoscaling is running. Once 
autoscaling has completed, the autoscale dialog is displayed. You can undo 
the autoscaling or close the dialog. Autoscaling can be performed from the 
front panel or the graphical interface.

Use the following procedures to enable the autoscale.

Front panel

To perform autoscaling, press  in the Horizontal section as shown in 
Figure 2- 36.

Figure 2-36  Autoscale button in the Horizontal section

Graphical interface

1 Select Auto-Scale on the bottom right of the graphical interface as 
shown in Figure 2- 37.

Figure 2-37  Autoscale button on the graphical interface
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2 When the autoscale function is running, a notification dialog is 
displayed as shown in Figure 2- 38.

Figure 2-38  Autoscale notification dialog

3 Once autoscaling has completed, the Undo AutoScale? dialog is 
displayed as shown in Figure 2- 39. 

Figure 2-39  Undo AutoScale? dialog

4 Select Undo to undo the new settings, or select Close to close the Undo 
AutoScale? dialog. You can also undo autoscale from the Acquisition 
menu on the toolbar.

NOTE Autoscaling may take a few seconds to complete.

NOTE The Undo AutoScale? dialog will automatically close after 5 seconds.
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Accessing the Trigger Setup

The trigger source can be set to channel 1, 2, 3, or 4, or AUX. For the 
channel trigger source, you can set the trigger sweep, slope, level, and 
holdoff. For the AUX trigger source, the trigger level setting is disabled. 
The 8990B allows you to configure the trigger settings from the Trigger 
section on the front panel and the Trigger menu on the graphical 
interface.

Use the following procedures to access the trigger setup.

Front panel

1 To configure the trigger settings, use the individual buttons and knob in 

the Trigger section, or press  to access the Trigger Setup dialog as 
shown in Figure 2- 40.

Figure 2-40  Menu button in the Trigger section

2 For more information on the Trigger Setup dialog, refer to “Graphical 
interface”.
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Graphical interface

1 To configure the trigger settings, select the individual buttons on the 
Trigger menu to toggle between selections or access the menu dialog as 
shown in Figure 2- 41.

Figure 2-41  Trigger menu on the graphical interface

Source

Select either channel or AUX as the trigger source. The channel selection 
depends on the connected sensors or probes.

Sweep

Select either auto trigger sweep mode, or normal trigger sweep mode.

Slope

Set the trigger point to the positive slope or negative slope of the signal.

Trigger menu

Trigger holdoff

Trigger level

Trigger slope

Sweep mode

Trigger source
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Level

Set the trigger level value to determine the position of the trigger point.

Holdoff

Set the trigger holdoff value to keep the trigger from occuring until after a 
certain amount of time has passed since the last trigger.

Menu

Display the trigger setup dialog.

2 The Trigger Setup dialog is displayed as shown in Figure 2- 42.

Figure 2-42  Trigger Setup dialog

3 You can set the trigger mode, trigger sweep mode, trigger count, trigger 
source, trigger level, and trigger slope from the Trigger Setup dialog. 
Trigger count is only applicable when the trigger mode is By Event. 
Trigger On, T1, and T2 are only applicable when the trigger mode is 
Pulse Width.

4 Select Conditioning... on the Trigger Setup dialog to display the Trigger 
Conditioning dialog as shown in Figure 2- 43.
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Figure 2-43  Trigger Conditioning dialog

5 You can set the trigger holdoff, impedence, hysteresis, and enable or 
disable the fast trigger and trigger output.

Fast Trigger

Fast Trigger is essentially a triggering mode where the 8990B sends out a 
trigger signal whenever the input RF signal crosses the trigger threshold. 
This is useful for application that requires fast trigger response. When 
Fast Trigger is disabled, the trigger out is sent only for every capture.

NOTE Trigger out signal

The behaviors of the trigger out signal with different channel source are listed as follows.

RF input channel 1/4 as the trigger source.

• With fast trigger on, the trigger output pulse train resembles the RF input channel. 
The trigger output varies according to the RF input pulse with PRF less than 1 MHz. 

• Fast Trigger is essentially a triggering mode where the 8990B sends out a trigger signal 
whenever the RF input signal crosses the trigger threshold. This is useful for application 
that requires fast trigger response. When Fast Trigger is disabled, the trigger out is sent 
only for every capture. 

• With fast trigger off, the trigger output pulse is 1 μs pulse/capture.

Video input channel 2/3 as the trigger source with a sensor connected.

• The trigger output pulse is 1 μs pulse/capture.

Video input channel 2/3 as the trigger source without any sensor connected.

• The trigger output pulse is 25 ns pulse/capture.
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Setting the Measurement Threshold

The measurement thresholds setting customizes the measurement 
parameters which are amplitude sensitive such as rise time, fall time, and 
pulse width. The threshold setting enables you to distinguish a valid 
measurement from a questionable measurement. The default threshold is 
0%. 

When a threshold is set, the time- related measurement result will be 
prefixed with a question mark, ?, if it falls below the threshold value. This 
is useful to distinguish an invalid measurement as a result of over 
zooming into a measured pulse top or pulse base.

NOTE The measurement result will return a question mark if the product of the pulse top and 
pulse base is lower than the threshold set.

If the vertical scale is in dB/div (log power display), the calculation is as follows.

10Log(Pulse top (W) / |Pulse base (W)|) < Threshold × Vertical scale

If the vertical scale is in W/div (linear power display), the calculation is as follows.

(Pulse top – Pulse base) < Threshold × Vertical scale

For example,

Pulse top: 0 dBm (1 mW)
Pulse base: –69 dBm (0 W)
Vertical scale: 12 dB
Threshold: 50%

10Log (1 mW/0 mW) < 50% × 12 dB
0 dB < 6 dB (invalid measurement)
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Use the following procedure to set the measurement threshold.

1 Select Setup > Measurement Thresholds on the toolbar as shown in 
Figure 2- 44.

Figure 2-44  Measurement Thresholds selection in the Setup menu

2 The Measurement Thresholds dialog is displayed as shown in 
Figure 2- 45 to allow you to configure the threshold settings for each 
channel.

Figure 2-45  Measurement Thresholds dialog

Source

Set the measurement threshold source to channel 1, 2, 3, or 4.
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Thresholds

Set the measurement threshold value in percentage.

Trace Ref Lv 1 and 2 (%)

Use in the calculation of transition durations and occurrences. 

Pulse Duration Ref Lvl (%)

Allow pulse duration measurements between non- standard reference 
levels.
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Saving and Loading Waveform Memories

The 8990B allows you to save and load the waveform memories.

Use the following procedures to save and load waveform memories.

Saving waveform memories

1 Select File > Save Waveform... on the toolbar to save the current 8990B 
waveform data as a *.csv file as shown in Figure 2- 46.

Figure 2-46  Save Waveform... selection in the File menu

2 The Save Waveform dialog is displayed. You can select the input channel 
to be saved by selecting Waveform Source to display the input channel 
list.

3 Select Keyboard on the Save Waveform dialog to display the on- screen 
keyboard as shown in Figure 2- 52. This is useful when there is no 
keyboard connected to the 8990B.
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Loading waveform memories

Select File > Load Waveform... on the toolbar to load a *.csv waveform data 
file as shown in Figure 2- 47.

Figure 2-47  Load Waveform... selection in the File menu

You can also set four waveform memories and load the waveform data 
from the channels, waveform memories, or a CSV file from the Waveform 
Memory dialog.

Use the following procedure to configure the waveform memories.

1 Select Setup > Waveform Memory on the toolbar as shown in Figure 2- 48.

Figure 2-48  Waveform memory selection in the Setup menu
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2 The Waveform Memory dialog is displayed as shown in Figure 2- 49.

Figure 2-49  Waveform Memory dialog

3 Select the On check box to enable the waveform memory. You can set 
the vertical scale and offset. Select the m1, m2, m3, or m4 tab to toggle 
among the four available waveform memories.

4 Select Load From Waveform to load the waveform from channel 1 to 4 or 
waveform memory as shown in Figure 2- 50. The waveform memory 
selection is only available if the waveform memory is enabled.

Figure 2-50  Load from waveform selection

5 Select Load From File to load the waveform from a CSV file. 

6 The Load Waveform dialog is displayed as shown in Figure 2- 51. You 
can select the waveform memory for the waveform data file to load into 
by selecting the Load to memory to display the waveform memory list.
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Figure 2-51  Load waveform from file

7 Select Keyboard on the Load Waveform dialog to display the on- screen 
keyboard as shown in Figure 2- 52. This is useful when there is no 
keyboard connected to the 8990B.

Figure 2-52  On-screen keyboard
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Performing Waveform Math Operations

The 8990B allows you to perform math operations on a pair of channels 
with the same measurement unit.

Use the following procedure to perform waveform math operations.

1 Select Setup > Waveform Math on the toolbar as shown in Figure 2- 53.

Figure 2-53  Waveform Math selection in the Setup menu

2 The Waveform Math dialog is displayed as shown in Figure 2- 54 to 
allow you to select the channel source and the type of math operation 
to perform. The available math operations are Add, Averaging, Common 
mode, Divide, Invert, Magnify, Multiply, Power- added efficiency, 
Power- added efficiency 2, Subtract, Square, and Square Root.

3 Denominator clipping is only available for math operations that involve 
division such as Divide, Power- added efficiency, and Power- added 
efficiency 2. Displaying the trace in percentage settings are only 
applicable for Power- added efficiency and Power- added efficiency 2 
math operations.

4 Select the On check box to display the desired math operation result.
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Figure 2-54  Waveform Math dialog

5 You can select the Func1 or Func2 button to access the math operation 
setup for the desired math operation function. You may choose to 
display either one or both of the math operation function.

6 The resultant trace waveform of the math operation is displayed on the 
display layout in white or green depending on the math operation 
function used. 

7 An example of a resultant trace waveform is displayed as shown in 
Figure 2- 55.

Figure 2-55  Resultant trace waveform of the math operation
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Add

The add math operation adds source 1 and source 2 trace values, point by 
point.

Figure 2-56  Add

NOTE • If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the add math operation. The resultant trace is then converted back to dBm.

• If the trace length between the channels is not equal, the waveform math operation will 
find the shortest trace between the sources and shrink other traces to an equal length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.
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Averaging

The 8990B allows you to perform the Averaging math operation that 
acquires the waveform data from several acquisitions and averages the 
traces. The higher the average count is, the less impact each new 
waveform has on the cumulative- averaged waveform. It is different with 
video averaging as it performs only on a single channel.

Figure 2-57  Averaging

Setting the averaging math operation

1 Select Average at the Waveform Math dialog as shown in Figure 2- 57.

2 When the waveform math is enabled, the elapsed average count will 
start to update, showing the number of waveforms that is acquired.

3 The example in Figure 2- 57 acquires 10 traces from channel 1 and 
averages the traces point by point. It calculates the average of each data 
point. After the elapsed average count is reached, the previously 
acquired trace will be removed and replaced with a newly acquired 
trace.
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Common mode

The common mode math operation is used to look for the common mode 
component of the differential waveforms. This operation will add source 1 
and source 2 trace values and divides the value by two, point by point.

Figure 2-58  Common Mode

NOTE • If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the common mode math operation. The resultant trace is then converted back to dBm.

• If the trace length between the channels is not equal, the waveform math operation will 
find the shortest trace between the sources and shrink other traces to an equal length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.
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Divide

The divide math operation divides source 1 and source 2 trace values, 
point by point.

Figure 2-59  Divide

NOTE • If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the divide math operation. The resultant trace is then converted back to dB.

• If the trace length between the channels is not equal, the waveform math operation will 
find the shortest trace between the sources and shrink the other trace to an equal 
length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.
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Invert

The invert math operation inverts the sign of the waveform trace values, 
point by point.

Figure 2-60  Invert
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Magnify

The magnify math operation allows you to magnify or reduce the source 1 
waveform in vertical directions. This operation is performed on an 
acquired waveform. Therefore, the resolution is the same as the original 
acquisition no matter how large the waveform is magnified.

Figure 2-61  Magnify
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Multiply

The multiply math operation multiplies source 1 and source 2 trace values, 
point by point.

Figure 2-62  Multiply

NOTE • If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the multiply math operation. The resultant trace will have the undefined (UDF) unit.

• If the trace length between the channels is not equal, the waveform math operation will 
find the shortest trace between the sources and shrink other traces to an equal length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.
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Power-added efficiency

The 8990B allows you to perform power- added efficiency measurements. 
Power- added efficiency is the measure of the power conversion efficiency 
of the power amplifiers. The formula for power- added efficiency is as 
follows:

PRFout = Power in watts, which can be set to RF input channel 1 or 4

PRFin = Power in watts, which can be set to RF input channel 1 or 4

PDC = VDC – IDC

VDC = Voltage supplied, which can be set to video input channel 2 or 3

IDC = Current supplied, which can be transduce voltage from video input channel 2 or 3

For example, IDC = Voltage across (V)/Resistance (Ω) = (1/R) video input channel 2 or 3

Power-added efficiency (in %) PRFout PRFin–( ) PDC⁄[ ] 100%×=

PRFout PRFin–( ) VDC IDC–( )⁄[ ] 100%×=

NOTE • If the amplifier gain is more than 30 dB, the nominator can be set to a single RF input 
channel. 

• The power-added efficiency result is an absolute and non-negative value. 

• The denominator PDC must be a real and non-zero value. 

• The dBm and power conversion formula is 10 × log (power/1 mW)

• If the trace lengths among the channels are not equal, the waveform math operation will 
find the shortest trace among the sources and shrink the other traces to an equal length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.

• If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the power-added efficiency measurement.
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Setting the power-added efficiency measurement

1 Select Power-added efficiency at the Waveform Math dialog as shown in 
Figure 2- 63.

Figure 2-63  Power-added efficiency

2 Select the On check box to display the power- added efficiency 
measurement result.

3 Compare the setting at the Waveform Math dialog with the power- added 
efficiency formula.

Pgain = Channel 1 = PRFout – PRFin

Vdc = 10 × Channel 2

Idc = (1/R) Channel 3 = 0.02 × Channel 3
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4 Toggle the X button to select between the multiplication symbol (x) or 
division symbol (/) as the symbol type. If the multiplication symbol (x) 
is used, the constant value sent through SCPI will be updated in the 
text box accordingly. If the division symbol (/) is used, the constant 
value sent through SCPI will be displayed as 1/(constant value) in the 
text box.

Figure 2-64  Power-added efficiency with the division symbol type

5 The calculated power- added efficiency measurement result is in %. 

6 Unselect the Display trace in percentage check box to display the result in 
ratio. 
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Setting the power-added efficiency 2 measurement

1 Select Power-added efficiency 2 at the Waveform Math dialog as shown in 
Figure 2- 65.

Figure 2-65  Power-added efficiency 2 with multiplication symbol (x)

2 Select the On check box to display the power- added efficiency 
measurement result.

3 Compare the setting at the Waveform Math dialog with the power- added 
efficiency formula.

Pout = Channel 1 = PRFout

Pin = Channel 4 = PRFin

Vdc = 10 × Channel 2

Idc = (1/R) Channel 3 = 0.02 × Channel 3
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4 Toggle the X button to select between the multiplication symbol (x) or 
division symbol (/) as the symbol type. If the multiplication symbol (x) 
is used, the constant value sent through SCPI will be updated in the 
text box accordingly. If the division symbol (/) is used, the constant 
value sent through SCPI will be displayed as 1/(constant value) in the 
text box.

Figure 2-66  Power-added efficiency 2 with the division symbol type

5 The calculated power- added efficiency measurement result is in %. 

6 Unselect the Display trace in percentage check box to display the result in 
ratio.
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Subtract

The subtract math operation subtracts source 1 and source 2 trace values, 
point by point.

Figure 2-67  Subtract

NOTE • If the source(s) input is in the log scale, it will be converted to the linear scale to perform 
the subtract math operation. The resultant trace is then converted back to dBm.

• If the trace length between the channels is not equal, the waveform math operation will 
find the shortest trace between the sources and shrink other traces to an equal length.

• If the number of trace points is not equal, the waveform math operation will add trace 
points by using the PCHIP method.
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Square

The square math operation squares the channel waveform, point by point.

Figure 2-68  Square
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Square root

The square root math operation calculates the squsre root of source 1, 
point by point.

Figure 2-69  Square root

NOTE If any of the source 1 trace points is less than zero, it will be clipped to zero as the square 
root operation is not able to calculate negative values.
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Setting the Frequency-Dependent Offset (FDO)

FDO tables provide a quick and convenient method of compensating for 
frequency- related changes. When selected, frequency- dependent offset 
corrections are applied in addition to any correction for RF input 
channels frequency response. The 8990B is capable of storing 10 
frequency- dependent offset tables with a maximum of 80 frequency points 
each.

Use the following procedure to set the FDO tables.

1 Select Tools > FDO on the toolbar as shown in Figure 2- 70.

Figure 2-70  FDO selection in the Tools menu

2 The FDO Table dialog is displayed as shown in Figure 2- 71 to allow you 
to select and configure the FDO table.
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Figure 2-71  FDO Table dialog

3 Select the desired custom FDO table name, and select either the 
A Table or B Table check box, or both to set the custom FDO table state 
to apply on RF input channel 1 or 4, or both channels.

4 To display the custom FDO table data dialog, select the desired custom 
FDO table name, and select Edit as shown in Figure 2- 72, or 
double- click or double- touch the desired custom FDO table name.

Figure 2-72  Edit button
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5 The selected custom FDO table data dialog is displayed as shown in 
Figure 2- 73.

Figure 2-73  Custom FDO table data dialog

6 Select Insert to add a new frequency point. Insert the desired frequency 
point and offset in the New Data dialog as shown in Figure 2- 74.

Figure 2-74  New Data dialog

7 The FDO status is displayed in the Status view as shown in 
Figure 2- 75. For more information on the Status view, refer to “Status 
view” on page 107.

Figure 2-75  FDO status in status view
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Magnifying a Section of the Waveform Using Zoom

The Zoom function allows you to magnify a section of the waveform up to 
30 times of the current horizontal scale.

Use the following procedures to magnify a section of the waveform.

Front panel

1 To perform the zoom function, press  in the Horizontal section as 
shown in Figure 2- 76.

Figure 2-76  Zoom button in the Horizontal section

2 Press  in the Horizontal section to close the zoom function.

Graphical interface

1 Select Acquisition > Zoom on the toolbar as shown in Figure 2- 77.

Figure 2-77  Zoom selection in the Acquisition menu
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2 A rectangle frame is displayed at the main graph window to indicate 
the area that is magnified as shown in Figure 2- 79. The magnified 
section of the waveform is displayed below the main graph.

Figure 2-78  Rectangle frame at the main graph window in zoom display layout

3 Adjust the horizontal scale to increase or decrease the magnified area, 
or adjust the horizontal offset to shift the rectangle at the main graph 
window.

NOTE You can also use the horizontal scale and offset knobs at the horizontal section in the front 
panel to adjust the scaling. The horizontal scale knob is adjustable in factors of 1, 2, 
and 5.
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4 The Measurement view on the multi- purpose pane will display the 
measurement results of the magnified section of the waveform as shown 
in Figure 2- 79.

Figure 2-79  Measurement view in zoom display layout

5 Select Acquisition > Zoom on the toolbar to close the Zoom function.
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Splitting the Waveform Screen

The 8990B allows you to separate the waveform display to four split 
screens according to the channels.

1 Select Acquisition > Split Screen on the toolbar as shown in Figure 2- 80.

Figure 2-80  Split Screen selection in the Acquisition menu

2 An example of the split screen is as shown in Figure 2- 81.
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Figure 2-81  Split screens
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Displaying the Complementary Cumulative Distribution Function 
(CCDF) Information

A CCDF curve is defined by how much time the waveform spends at or 
above a given power level. This is expressed in dB relative to the average 
power. A CCDF curve is a plot of relative power levels versus probability 
where the X- axis represents the dB above the average signal power, while 
the Y- axis represents the percent of time the signal spends at or above the 
power level specified by the X- axis.

The CCDF feature will display the CCDF curve on a separate graph. When 
the CCDF feature is used, you can toggle among four types of views to 
display on the multi- purpose pane: status view, table view, marker view, 
and log view.

Use the following procedure to display the CCDF information.

1 Select Acquisition > CCDF on the toolbar as shown in Figure 2- 82.

Figure 2-82  CCDF selection in the Acquisition menu

NOTE CCDF information is only available for RF input channels. When the CCDF feature is used, 
the video input channels will be disabled.
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2 The CCDF graph is displayed as shown in Figure 2- 83.

Figure 2-83  CCDF graph display in table view

3 The Table view on the multi- purpose pane will display the CCDF 
statistical information, peak, average, and peak to average measurement 
results as shown in Figure 2- 83.
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4 The Marker view displays the X- axis and Y- axis values for the markers, 
and the delta values between the two markers that you enabled on the 
trace as shown in Figure 2- 84.

Figure 2-84  Marker view in CCDF
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5 To configure the CCDF settings, select the individual buttons on the 
CCDF menu to toggle between selections or access the menu dialog as 
shown in Figure 2- 85.

Figure 2-85  CCDF menu on the graphical interface

Source

Toggle between channel 1 or channel 4 as the CCDF source.

Sweep

Toggle between Free or Triggered as the CCDF sweep mode.

CCDF source

CCDF sweep

CCDF slope

CCDF level

CCDF holdoff

Trigger conditioning

CCDF setup
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Slope

Toggle between positive and negative slope. This setting is only applicable 
when the CCDF sweep mode is Triggered.

Level

Set the CCDF level value. This setting is only applicable when the CCDF 
sweep mode is Triggered.

Holdoff

Set the CCDF holdoff value. This setting is only applicable when the CCDF 
sweep mode is Triggered.

Conditioning

Display the Trigger Conditioning dialog. This setting is only applicable 
when the CCDF sweep mode is Triggered.

Setup

Display the CCDF Setup dialog.

6 The Trigger Conditioning dialog is displayed as shown in Figure 2- 86. 

Figure 2-86  Trigger Conditioning dialog

7 You can set the trigger holdoff, impedance, hysteresis, and enable or 
disable the fast trigger and output. For more information on the trigger 
conditioning dialog, refer to “Accessing the Trigger Setup” on page 54.
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8 The CCDF Setup dialog is displayed as shown in Figure 2- 87.

Figure 2-87  CCDF Setup dialog

Scale

Set the CCDF vertical scale.

Counts

Set the CCDF count value. This setting is only applicable when the CCDF 
sweep mode is Free.

Duration × Frame

Set the CCDF duration and frame. The product of the CCDF duration and 
frame cannot be more than 100 s. This setting is only applicable when the 
CCDF sweep mode is Triggered.

Trace Display

Select among channel 1, channel 4, Gaussian, and reference channel to be 
displayed on the CCDF trace. The CCDF trace can be referenced to 
channel 1 or channel 4.
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Table Display

Select between Channel 1 or Channel 4 as the channel for the CCDF 
information to be displayed at the Table view.

9 Select Acquisition > CCDF on the toolbar to close the CCDF function.
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Accessing the Multipulse Mode

Multipulse is only available in the RF channels with a maximum of 512 
frames. It can be used to analyze the power amplifier or transmitter 
output stability by measuring the amplitude droop, pulse to pulse stability, 
and abnormal pulse. Multipulse is also able to capture and analyze 
continuous pulses, compare the pulses characteristics, and capture long 
PRI pulses or any multiple pulse trains or burst. The histogram in the 
multipulse mode is useful to analyze the jitter in rise time, fall time, and 
pulse width measurements of the pulse trains.

Use the following procedure to display the multipulse mode.

1 Select Acquisition > MultiPulse on the toolbar as shown in Figure 2- 88.

Figure 2-88  MultiPulse selection in the Acquisition menu

2 The MultiPulse Setup dialog is displayed as shown in Figure 2- 89 to 
allow you to configure the multipulse display.

Figure 2-89  MultiPulse Setup dialog



2 Operating Information

98 8990B User’s Guide

3 Insert the desired number of frames and histogram bin, and select the 
Time Stamp check box to display the time stamp on the multipulse 
display.

4 The multipulse status is displayed on the multi- purpose pane as shown 
in Figure 2- 90.

Figure 2-90  Multipulse status on the multi-purpose pane

5 An example of the multipulse display is as shown in Figure 2- 91.



Operating Information 2

8990B User’s Guide 99

Figure 2-91  Multipulse display

6 Select the arrows on the display to display the desired frames.

7 You can also display the MultiPulse Display dialog by selecting Advanced 
Settings from the Multipulse display.
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Multipulse measurement

1 The Measurement view on the multi- purpose pane will display the 
desired measurement results of the multipulse and the histogram data 
as shown in Figure 2- 92.

Figure 2-92  Measurement view in multipulse display

2 You can also select the measurement functions from the Measure menu 
on the toolbar.

3 The delta value between two pulses can also be displayed from the 
measurement view as shown in Figure 2- 92. Select Insert after selecting 
your desired pulses to display the delta value.

4 To remove the measurement functions results from the Measurement 
view, select the Measurement view area to display the delete 
measurement menu and select Delete > All Measurements. To remove only 
specific measurement function results, select the specific measurement 
fucntion or delta to be deleted as shown in Figure 2- 93.

Figure 2-93  To delete multipulse measurement results on the multi-purpose pane

5 Select the L button to display the measurement view in a separate 
dialog as shown in Figure 2- 94.
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Figure 2-94  Multipulse measurement view dialog

6 Select Acquisition > Multipulse on the toolbar to close the multipulse 
function.

Save the multipulse measurement

The 8990B allows you to save the multipulse measurement of the acquired 
waveform.

1 Select Acquisition > Save measurement > Multipulse on the toolbar to save 
the multipulse measurement data as a *.csv file as shown in 
Figure 2- 95.
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Figure 2-95  Save measurement... > Multipulse selection in the Acquisition menu

2 The Save dialog is displayed as shown in Figure 2- 96. You can select 
the input channel to be saved by selecting Waveform Source to display 
the input channel list.
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Figure 2-96  Save multipulse dialog
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Accessing the Display XY Mode

The 8990B allows you to have a new visualization of trace instead of the 
timebase X- axis. You can use the Display XY mode to select the X- axis 
source and Y- axis source. Based on the selected sources, the Display XY 
mode will draw a scatter trace on a separate graph. 

Display XY is useful to view two functional characters or measurement 
results. For example, in a power amplifier test, you can display the plot of 
Gain versus Power- IN. In a PAE test, plotting the PAE function versus 
power out or power in will be useful to understand the PAE 
characteristics of the power amplifier under test.

Use the following procedure to display the Display XY mode.

1 Select Acquisition > Display XY on the toolbar as shown in Figure 2- 97.

Figure 2-97  Display XY selection in the Acquisition menu

2 An example of the Display XY mode is as shown in Figure 2- 98.

NOTE If the X-axis source is in the linear scale, the origin will always start from a non-negative 
value.
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Figure 2-98  Display XY mode

3 The resultant trace is displayed in yellow. You can change the X- axis 
and Y- axis source below the Trigger menu.

4 Select the Reference check box to set the current displayed trace as the 
reference trace. The reference trace will be displayed in pink.

5 The DisplayXY Reference Trace dialog will be displayed as shown in 
Figure 2- 99 when you change the Display XY mode sources with the 
reference trace enabled.
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Figure 2-99  DisplayXY Reference Trace dialog

6 Select Yes or No to keep the current reference trace and redraw the 
trace according to the new sources scale or disable the reference trace.

7 Select Acquisition > Display XY on the toolbar to close the Display XY 
mode.

NOTE For the DisplayXY mode, the marker tracking style is set to Free Float.
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Accessing the Multi-Purpose Pane

The multi- purpose pane allows you to toggle among seven types of views 
to display — status view, measurement view, marker view, X-Y position 
view, droop measurement view, limit test view, and log view. The 
multi- purpose pane is located at the bottom of the graphical interface as 
shown in Figure 2- 100.

Use the following procedure to access the multi- purpose pane.

1 Select the Status, Measurements, Markers, X-Y Position, Droop, Limit Test, or 
Log tab to access the respective views.

Figure 2-100  Multi-purpose pane on the graphical interface

Status view

The Status view displays the general 8990B operating information, 
measurement acquisition functions status, and trigger settings information. 
The Status view displays all these information as shown in Figure 2- 101.

Figure 2-101  Status view on the multi-purpose pane
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Measurement view
The Measurement view displays the measurement results for different 
measurement functions. You can select the desired measurement functions 
to measure from the Measure menu in the graphical interface as shown in 
Figure 2- 102. You can also select the measurement functions from the 
Measure menu on the toolbar.

Figure 2-102  Measure functions menu on the graphical interface

Minimum power measurement

Next measurement list Previous measurement list

Peak power measurement

Average power measurement

Peak-to-average power 
measurement

Duty cycle measurement 

Pulse repetition interval 
(PRI) measurement

Pulse repetition frequency 
(PRF) measurement

Fall time measurement

Rise time measurement

Off time measurement

Pulse base measurement

Pulse top measurement

Pulse width measurement

Overshoot measurement
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The measurement functions available are minimum power, peak power, 
average power, peak- to- average power, duty cycle, PRI, PRF, fall time, rise 
time, off time, pulse base, pulse top, pulse width, and overshoot. You can 
also select the normal or zoom mode for the selected measurement to be 
displayed as shown in Figure 2- 103.

Figure 2-103  Measurement dialog

The Measurement view will display the current, mean, minimum, 
maximum, and standard deviation values for the selected measurement 
functions as shown in Figure 2- 104.

Figure 2-104  Measurement view on the multi-purpose pane

NOTE The Normal/Zoom mode selection is only available in the zoom function.

NOTE • The minimum and maximum values are retained if there are no changes in the settings 
which will invalidate the measurements. 

• The minimum and maximum value is reset when there are changes to the trigger 
parameters or horizontal scale. Clearing the waveform display will also reset the 
minimum and maximum value.
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1 To display the measurement results, select the measurement functions 
from the Measure menu on the graphical interface to measure as shown 
in Figure 2- 102.

2 To remove all measurement functions results from the Measurement 
view, select the Measurement view area to display the delete 
measurement menu and select Delete > All Measurements. To remove only 
specific measurement function results, select Delete > [measurement 
function] as shown in Figure 2- 105.

Figure 2-105  To delete measurement results on the multi-purpose pane

Marker view

The Marker view allows you to automatically track the X- axis and Y- axis 
values for the markers, and the delta amplitude and amplitude ratio 
values between the two markers that you enabled on the trace, as shown 
in Figure 2- 106. You can also measure delay and spacing measurements 
using the markers. The 8990B allows you to enable two markers, A and B.

NOTE The Measurement view is able to display results of up to six measurement functions.
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Figure 2-106  Marker view on the multi-purpose pane

Assign or change the channel for the markers

Use the following procedure to assign or change the channel for the 
markers.

1 To assign or change the channel for each marker, select the marker 
button at the bottom of the graphical interface as shown in 
Figure 2- 107.

Figure 2-107  Marker buttons on the graphical interface

2 You can also press  in the Measure section on the front panel as 
shown in Figure 2- 108 or select Tools > Marker on the toolbar.

Figure 2-108  Markers button in the Measure section

3 The Markers dialog is displayed on the graphical interface as shown in 
Figure 2- 109.
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Figure 2-109  Markers dialog

4 Select the Track Waveform/Free Float button to toggle between the Track 
Waveform mode and Free Float mode. The track waveform mode sets 
the marker vertices to be always tight with the waveform power level. 
The free float mode allows the markers to move freely on the 
graph area.

5 Select the marker A or B button to select the channel for the respective 
marker.

6 Select Search A or Search B and set the X value to search for a specific 
X- axis value.

7 You can also set the Y value to search for a specific Y- axis value. Refer 
to “X-Y position view” on page 117 for more information.

8 Select Refresh to refresh the marker position based on the X value.

9 Select Reset to reset the markers.

Marker A button Marker B button
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Select and move the markers

Use the following procedure to select and move the markers.

1 Push  in the Measure section on the front panel to select or toggle 

between markers A and B as shown in Figure 2- 110.

Figure 2-110  Select knob in the Measure section

2 When selecting or toggling between markers, the marker indicator is 
displayed on the graphical interface as shown in Figure 2- 111.

Figure 2-111  Marker indicator on the graphical interface

3 To change the position of the marker, turn  , or select the marker 
label on the graphical interface and drag the marker to the desired 
position as shown in Figure 2- 112.

Figure 2-112  Marker labels on the graphical interface
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Delay measurement

The delay measurement function is useful when measuring time separation 
between two different channels. When this function is turned on, the 
markers are automatically positioned on the rising edge or falling edge of 
the measured channels, depending on the slope type set.

Use the following procedure to set the delay measurement.

1 Select Delay Measurement in the Marker view as shown in Figure 2- 113.

Figure 2-113  Delay Measurement button in the Marker view

2 The Delay Measurement Setup dialog is displayed as shown in 
Figure 2- 114.

Figure 2-114  Delay Measurement Setup dialog

3 Select the desired marker channels, slope position, and set the trace 
reference level to set the delay measurement. The marker will be 
automatically placed at the specified reference level.

4 Select Apply or OK to turn on the delay measurement function.
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5 The delay measurement results will be displayed on the Delta row in 
the Marker view and the Delay Measurement button is highlighted when it 
is turned on as shown in Figure 2- 115.

Figure 2-115  Delay measurement in the Marker view

Spacing measurement

The spacing measurement function measures the delay in between pulses. 
When this function is turned on, the markers are automatically positioned 
on the rising edge or falling edge of the specified pulse.

Use the following procedure to set the spacing measurement.

1 Select Spacing Measurement in the Marker view as shown in 
Figure 2- 116.

Figure 2-116  Spacing Measurement button in the Marker view

NOTE If the position of the marker is changed manually, the delay measurement is turned off and 
reverted to the manual marker mode.
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2 The Spacing Measurement Setup dialog is displayed as shown in 
Figure 2- 117.

Figure 2-117  Spacing Measurement Setup dialog

3 Select the desired trace channel and slope position, and set the pulse 
number and trace reference level for the spacing measurement.

4 Select Apply or OK to turn on the spacing measurement function.

5 The spacing measurement results will be displayed on the Delta row in 
the Marker view and the Spacing Measurement button is highlighted when 
it is turned on as shown in Figure 2- 118.

Figure 2-118  Spacing measurement in the Marker view

NOTE • If the position of the marker is changed manually, the spacing measurement is turned off 
and reverted to the manual marker mode.

• When in zoom mode, the spacing measurement pulse number is referenced to the 
zoom trace.
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X-Y position view

The X-Y position view allows you to search for a specific Y- axis value 
using the markers.

Figure 2-119  X-Y Position view

1 Select Markers Search in the X-Y Position view or press Markers in the 
Measure section on the front panel. 

2 The Markers dialog is displayed as shown in Figure 2- 120.

Figure 2-120  Markers dialog

3 Select the Track Waveform/Free Float button to toggle between Track 
Waveform mode and Free Float mode. The track waveform mode sets 
the marker vertices to be always tight with the waveform power level. 
The free float mode allows the markers to move freely on the 
graph area.
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4 Select Search A or Search B and set the Y value to search for a specific 
Y- axis value. 

5 Select Refresh to refresh the marker position based on the X value. 

6 Select Reset to reset the markers. 

7 Select Clear A or Clear B in the X-Y Position view to reset the respective 
markers Y value search results.

Figure 2-121  X-Y position search results

Droop measurement view

The Droop measurement view is used to measure the amount of droop, AD 
of the input signal as shown in Figure 2- 122. This function is only 
applicable for RF input channels.

Figure 2-122  Droop measurement graph
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Pulse amplitude, AM

The pulse amplitude quantity is determined by the intersection of a line 
passing through the points on the leading edge, where the instantaneous 
value reaches 10% and 90% of AM and a straight line that is the best 
least- squares fit to the pulse in the pulse- top region (usually this is fitted 
visually rather than numerically). For pulses deviating greatly from the 
ideal trapezoidal pulse shape, a number of successive approximations may 
be necessary to determine AM.

Trailing edge (last transition) amplitude, AT

The trailing edge amplitude quantity is determined by the intersection of a 
line passing through the points on the trailing edge where the 
instantaneous value reaches 90% and 10% of AT, and the straight- line 
segment fitted to the top of the pulse in determining AM.

Droop, AD

Droop is the difference between AM and AT. It is expressed in percentage 
of AM.

Use the following procedure to set the droop measurement.

1 Select Droop Measurement in the Droop view as shown in Figure 2- 123.

Figure 2-123  Droop Measurement button in the Droop measurement view

2 The Droop Measurement Setup dialog is displayed as shown in 
Figure 2- 124.
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Figure 2-124  Droop measurement Setup dialog

3 Enable the droop measurement function and select the desired RF input 
channel.

4 The droop measurement results will be displayed in the Droop 
Measurement view as shown in Figure 2- 125.

Figure 2-125  Droop measurement view on the multi-purpose pane

Limit test view

Limit test view allows you to track the trace values that are above or 
below the upper limit and lower limit values respectively.

1 Select Tools > Limit Test... on the toolbar as shown in Figure 2- 126.

Figure 2-126  Limit test... selection in the Tools menu
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2 The Limit Test dialog is displayed as shown in Figure 2- 127.

Figure 2-127  Limit Test dialog

3 Select the Enable Upper Limit or Enable Lower Limit check box to enable the 
upper limit or lower limit feature respectively. You can set the upper 
limit and lower limit to your desired values. 

4 The limit test results are displayed in the Limit Test view as shown in 
Figure 2- 128.

Figure 2-128  Limit test results

5 Select Upper or Lower to view the limit test results for the upper limit 
and lower limit respectively. 
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Log view

The log view displays the 8990B error status information as shown in 
Figure 2- 129. 

Figure 2-129  Log view on the multi-purpose pane

Use the following procedure to view more information on the log 
messages.

1 If the 8990B encounters any operation faults while performing 
acquisitions and measurements, error messages will be displayed.

2 Select Clear in the Log view to clear the status information.

3 Double- click or double- touch on a log status message to view more 
information.

4 The Log dialog is displayed as shown in Figure 2- 130.

Figure 2-130  Log dialog
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Performing Zeroing and Calibration

The 8990B performs internal zeroing and calibration routines on the 
wideband power sensor. The internal zeroing and calibration processes are 
used to combine the wideband power sensor and the 8990B to make 
accurate power measurements.

Zeroing

Zeroing adjusts the 8990B for a zero power reading on each RF input 
channel and wideband power sensor combination. When the wideband 
power sensor is plugged into the 8990B, zeroing will start automatically. 
This can be achieved without removing the sensor from the power source. 
The 8990B is automatically set to zero- on- the- fly while you are using it. 
The 8990B also allows you to manually perform zeroing of the sensor from 
the Channel Setup dialog as shown in Figure 2- 131. 

Refer to “Accessing the Channel Setup” on page 31 for more information 
on the Channel Setup dialog.

Figure 2-131  Zero button on the Channel Setup dialog

Zeroing status
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Calibration

Calibration sets the gain of each RF input channel and wideband power 
sensor combination. This can be achieved without connecting the sensor to 
the 1 mW power reference. The 8990B is automatically set to 
calibrate- on- the- fly while you are using it. The 8990B auto- calibration is 
enabled by default. You can enable or disable the auto- calibration process 
and notification, and set the auto- calibration interval from the Auto Cal 
dialog.

Use the following procedure to enable the auto- calibration.

1 Select Tools > Auto Cal... on the toolbar as shown in Figure 2- 132.

Figure 2-132  Auto Cal... selection in the Tools menu

2 The Auto Cal dialog is displayed as shown in Figure 2- 133. 

Figure 2-133  Auto Cal dialog
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3 You can enable or disable the auto- calibration process and notification, 
and set the auto- calibration interval. The minimum interval is 1 minute 
and maximum interval is 60 minutes.

4 The 8990B also allows you to manually perform calibration of the 
sensor from the Channel Setup dialog as shown in Figure 2- 134. 

Figure 2-134  Cal and Zero & Cal buttons on the Channel Setup dialog

5 You can also perform zeroing and calibration of the sensor with the 
Zero & Cal button as shown in Figure 2- 134. Refer to “Accessing the 
Channel Setup” on page 31 for more information on the Channel Setup 
dialog.

Calibrating status
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Sensor Check Source

The sensor check source is used during delay calibration for RF input 
channel 1 and 4, and to verify that the wideband power sensor is 
operational. The sensor check source outputs an RF carrier of 1.05 GHz 
with a modulating pulse train signal of 1 kHz from a Type- N female 
connector. The RF level is 0 dBm at the carrier frequency. The sensor 
check source reference frequency can be set to Off, 1 kHz pulse, 50 MHz 
CW, or 1.05 GHz CW.

Use the following procedure to set sensor check source.

1 Select Tools > Check Source on the toolbar as shown in Figure 2- 135.

Figure 2-135  Check Source selection in the Tools menu

2 The Check Source dialog is displayed as shown in Figure 2- 136 to allow 
you to configure the check source settings.

Figure 2-136  Check Source dialog

3 You can set the reference frequency and the number of calibration 
intervals for the sensor check source.
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Reference Frequency

The reference frequency can be set to Off, 1 kHz pulse, 50 MHz CW, or 
1.05 GHz CW.

Calibration Interval

The calibration interval can be set to a range of 1 to 60 minutes.
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Saving the Screen

The 8990B allows you to save the graphical interface screen to an image 
file.

Use the following procedure to save the screen.

1 Select File > Save Screen... on the toolbar to save the screen image as 
shown in Figure 2- 137.

Figure 2-137  Save Screen... selection in the File menu

2 Save the screen image to your desired directory.

3 Select File > Save Screen (Printer Friendly) on the toolbar to save the screen 
image in black and white.
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Saving and Restoring 8990B States

The 8990B allows you to save and restore the 8990B states. Saving the 
current state will help to reduce repeated setup sequences.

Use the following procedures to set the save and restore the 8990B states.

Saving 8990B states

1 Select File > Save Current Setup... on the toolbar to save the current 8990B 
state to your desired directory in an XML file as shown in 
Figure 2- 138.

Figure 2-138  Save Current Setup... selection in the File menu

2 Select Keyboard on the Save Current Setup dialog to display the 
on- screen keyboard as shown in Figure 2- 52. This is useful when there 
is no keyboard connected to the 8990B.

NOTE The 8990B automatically retains the current state upon power cycle or in the event of 
interrupted power.
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Restoring 8990B states

1 Select File > Restore Saved Setup... on the toolbar to load a saved 8990B 
state from an XML file as shown in Figure 2- 139.

Figure 2-139  Restore Saved Setup... selection in the File menu

2 Select Keyboard on the Restore Saved Setup dialog to display the 
on- screen keyboard as shown in Figure 2- 52. This is useful when there 
is no keyboard connected to the 8990B.
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Logging and Saving the Measurement Data

The 8990B allows you to log and save the measurement results.

1 Select Acquisition > Save measurement... > Normal mode on the toolbar as 
shown in Figure 2- 140.

Figure 2-140  Save measurement > Normal mode selection in the Acquisition menu

2 Alternatively, you can also select the Measurement Logging button on 
the bottom left of the graphical interface as shown in Figure 2- 141. The 
Measurement Logging button is only applicable in the normal mode.

Figure 2-141  Measurement logging buttons on the graphical interface

3 The Measurement Logging dialog is displayed as shown in Figure 2- 142.

Measurement logging button
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Figure 2-142  Measurement Logging dialog

4 Select the desired measurement function check boxes to be included in 
the measurement logging. 

5 You can schedule a time to record the data or start recording by 
selecting Start. 

6 The 8990B also allows you to save a schedule to start logging the 
measurement data. 
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Generating and Saving a Report

The 8990B allows you to generate and save a report.

1 Select File > Save Report... on the toolbar as shown in Figure 2- 143.

Figure 2-143  Save Report... selection in the File menu

2 The Report dialog is displayed as shown in Figure 2- 144.
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Figure 2-144  Report dialog

3 Select the desired information check boxes to be included in the report. 
You can also add your description to the report. 

4 Select Keyboard on the Report dialog to display the on- screen keyboard. 
This is useful when there is no keyboard connected to the 8990B. 

5 Select OK to generate the report with the desired information. 

6 An example of the generated report is as shown in Figure 2- 145.
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Figure 2-145  Generated report

7 Select File > Save As to save the report.
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Secure Erase

The secure erase feature will erase the battery backed SRAM, the flash file 
system, and the secure blank password stored in the EEPROM. The flash 
file system includes the 8990B states, calibration factor tables, and 
frequency- dependent offset tables. Upon completion, the 8990B will be 
initialized to the default settings.

Use the following procedure to perform secure erase.

1 Select Tools > Secure Erase... on the toolbar as shown in Figure 2- 146.

Figure 2-146  Secure Erase... selection in the Tools menu

2 The Secure Erase confirmation dialog is displayed as shown in 
Figure 2- 147. Select OK to perform the secure erase operation.

Figure 2-147  Secure Erase dialog

NOTE Secure erase may take a few minutes to complete.
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Restoring the 8990B to Factory Default Settings
You can restore the 8990B to its factory default settings from the front 
panel or the graphical interface.

Use the following procedures to restore the 8990B to the factory default 
settings.

Front panel

Press  in the Horizontal section as shown in Figure 2- 148.

Figure 2-148  Default Setup button in the Horizontal section

Graphical interface

1 Select File > Restore Default Setup on the toolbar to restore the 8990B to 
its factory default settings as shown in Figure 2- 149.

Figure 2-149  Restore Default Setup selection in the File menu
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2 When restoring the 8990B to its factory default settings, a notification 
dialog is displayed as shown in Figure 2- 150.

Figure 2-150  Restoring PPA setup notification dialog

Table 2-2 8990B factory default settings

Feature Default setting

Averaging Disabled

Auto-ETS Enabled

Trigger

Source

Sweep

Slope

Level

Holdoff

Mode

Output

Fast Trigger

Hyteresis

Impedance

Source 1

Auto

Pos

0 dBm

1 μs

Edge

Enabled

Disabled

0 dB (Channel 1, 4)

NORMAL (Channel 2 , 3)

50 Ohm

Calibration

Auto-cal

Notify

Interval

Enabled

Enabled

10 min
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CCDF

Scale

Sweep

Source

Count

Duration

Frame

Trace display

Channel (1,4)

Gaussian

Reference

Store Reference

5 dB

Free

Source 1

100 M

10 ms

1

Enabled

Enabled

Disabled

Channel 1

Check Source

Reference Frequency

Calibration Interval

Off

1 min

Table 2-2 8990B factory default settings (continued)

Feature Default setting
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Configuring the Display Settings

Use the following procedure to configure the display settings.

1 Select Setup > Display Setup on the toolbar as shown in Figure 2- 151.

Figure 2-151  Display Setup selection in the Setup menu

2 The Display Setup dialog is displayed as shown in Figure 2- 152.

Figure 2-152  Display Setup dialog

3 Select each respective check box to display the trace lines, track the 
waveform minimum and maximum, or show the waveform minimum 
and maximum line. The waveform minimum and maximum tracking 
feature will shade the area between the minimum and maximum traces.
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4 An example of the waveform display with the waveform minimum and 
maximum tracking feature enabled is as shown in Figure 2- 153.

Figure 2-153  Example of the waveform display with the waveform minimum and maximum 
tracking feature enabled
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Remote Setup

Use the following procedure to view the remote setup parameters.

1 Select Tools > Remote Setup... on the toolbar as shown in Figure 2- 154.

Figure 2-154  Remote Setup... selection in the Tools menu

2 The Remote Setup dialog is displayed as shown in Figure 2- 155. The 
remote setup parameters are listed in the Remote Setup dialog.

Figure 2-155  Remote Setup dialog
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This chapter describes the built- in self- tests, error messages, and general 
maintenance of the 8990B peak power analyzer.
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Front Panel Test

The 8990B allows you to verify the 8990B front panel keys and knobs.

1 Select Tools > Front Panel Test... on the toolbar as shown in Figure 3- 1.

Figure 3-1 Front Panel test... selection in the Tools menu

2 The Front Panel Test dialog is displayed as shown in Figure 3- 2.

NOTE Remove all the input and output connections from the 8990B before performing the front 
panel test.
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Figure 3-2 Front Panel Test dialog

3 Press the front panel keys and knobs, and turn the knobs to verify that 
they are functioning. 

4 The corresponding keys and knobs on the Front Panel Test dialog 
illuminate green when they are verified.
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Figure 3-3 Front panel test results

5 Select Reset to reset the front panel test.
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Self-Test

The 8990B is designed to perform internal diagnostics. The self- test will 
run diagnostics on the test point voltages, fan, battery, PLL, channel peak 
paths, channel data acquisition points, and video. The 8990B self test can 
also be performed remotely.

Instrument self-test

Use the following procedure to perform instrument self- test.

1 Select Tools > Self Test... on the toolbar as shown in Figure 3- 4.

Figure 3-4 Self Test... selection in the Tools menu

2 The Self Test dialog is displayed as shown in Figure 3- 5.

NOTE Remove all the input and output connections from the 8990B before performing the 
self-test.
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Figure 3-5 Self Test dialog

3 Select Start to start the self- test.

4 The self- test result is displayed in the Self Test dialog as shown in 
Figure 3- 6.

Figure 3-6 Self-test result in the Self Test dialog
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Remote self-test

To invoke the remote self- test, the IEEE 488.1 compliant standard 
command, *TST? is used. This command runs a full self- test and returns 
one of the following codes:

• 0 — no tests failed

• 1 — one or more tests failed

When the *TST? command is executed, the screen is cleared. As each test 
takes place, the name of the test is listed on the screen. While a test is 
running, the message Testing... appears beside the name of the test. As 
each stage of the test is completed, the message Testing... is replaced by 
either the message Passed or Failed.

Test descriptions

Test point voltages

This test verifies the voltage rails.

Fan

This test confirms that the internal side cooling fan is operating.

Battery

This test checks the battery level.

PLL

This test verifies the phase lock loop status.

Channel 1/4 Measurement Path test

This test confirms that the RF input channel measurement path is 
functioning.
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Channel 1/4 Memory Interface test

This test confirms that the RF input channel memory interface is 
operating.

Video Ch

This test confirms that the video input channels are functioning.

Overall

This status indicates the overall self- test status.
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Error Messages

Introduction

This section contains information on error messages. It explains how to 
read the 8990B error queue and lists all the error messages and their 
probable causes.

When there is a hardware- related problem (for example, a sensor 
overload), the error is indicated in the Log view of the multi- purpose 
pane at the bottom of the display. In addition, errors are also written to 
the error queue. Any error in the error queue is displayed in the Log view 
as shown in Figure 3- 7.

Figure 3-7 Error log
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To read the error queue from the front panel:

• select the Log tab at the bottom of the display.

To read the error queue from the remote interface:

• use the SYSTem:ERRor? query.

Error queue messages have the following format:

Error queue message

For example, –113,"Undefined header;*T<Err> ST?".

Errors are retrieved in a first- in, first- out (FIFO) order. If more than 30 
errors occur, the error queue overflows and the last error in the queue is 
replaced with error –350,“Queue overflow”. Any time the queue overflows, 
the most recent errors are discarded. 

When the errors are read, they are removed from the error queue. This 
opens a position at the end of the queue for a new error message, if one 
is subsequently detected. When all errors have been read from the queue, 
further error queries return 0,“No error”. 

To delete all the errors in the queue from the front panel:

• select Clear in the Log view. 

To delete all the errors in the queue remotely:

• use the *CLS (clear status) command.

The error queue is also cleared when the 8990B power has been switched 
off.

Error
”; Device-Error

Description Dependent InfoNumber
“,
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Error list

0 No error

The error queue is completely empty. Every error or event in the queue has been read or 
the queue has been purposely cleared by power-on, *CLS, and so forth.

–100 Command error

Generic syntax error

–101 Invalid character

An invalid character was found in the command string. You may have inserted a 
character such as #, $, or % in the command header or within a parameter. 
Example: MARK:AXP 30#

–102 Syntax error

An invalid syntax was found in the command string 
Example: AUTO

–103 Invalid separator

An invalid separator was found in the command string. You may have used a comma 
instead of a colon, semicolon, or blank space; or you may have used a blank space 
instead of a comma. 
Example: ACQ:AVER:COUN,128

–105 GET not allowed

A Group Execute Trigger (GET) is not allowed within a command string

–109 Missing parameter

Fewer parameters were received than expected for the command. You may have omitted 
one or more parameters that are required for this command. 
Example: CHAN1:BWID

–110 Command header error

An error was detected in the header

–111 Header separator error

A character that was not a valid header separator was found in the command string



3 Maintenance

154 8990B User’s Guide

–112 Program mnemonic too long

A command header was received which contained more than the maximum 12 
characters allowed 
Example: SYSTemCOMMunicateLANDGATeway "10.0.0.2"

–113 Undefined header

A command was received that is not valid for the 8990B. You may have misspelled the 
command, it may not be a valid command, or you may have selected the wrong interface. 
If you are using the short form of the command, remember that it may contain up to four 
letters. 
Example: CHAN2:OFF 50

–114 Header suffix out of range

The value of the numeric suffix is invalid

–120 Numeric data error

Generic numeric data error

–121 Invalid character in number

An invalid character was found in the number specified for a parameter value 
Example: MARK:BXP 20$

–123 Exponent too large

A numeric parameter was found whose exponent was larger than 32000 
Example: CHAN1:FREQ 1E34000

–124 Too many digits

A numeric parameter was found whose mantissa contained more than 255 digits, 
excluding leading zeros

–128 Numeric data not allowed

A numeric value was received within a command which does not accept a numeric value
Example: CHAN1:REF 50

–130 Suffix error

Generic suffix error
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–131 Invalid suffix

A suffix was incorrectly specified for a numeric parameter. You may have misspelled the 
suffix. 
Example: CHAN2:INP LFRJ1

–134 Suffix too long

A suffix used contained more than 12 characters 
Example: CHAN2:INP LFR20000000000000

–138 Suffix not allowed

A suffix was received following a numeric parameter which does not accept a suffix 
Example: CHAN2:OFFS 50Hz

–140 Character data error

Generic character data error

–141 Invalid character data

Either the character data element contains an invalid character, or the element is not 
valid

–144 Character data too long

The character data element contains more than 12 characters

–148 Character data not allowed

A discrete parameter was received but a character string or a numeric parameter was 
expected. Check the list of parameters to verify that you have used a valid parameter 
type. 
Example: MARK:MODE OFF_0

–150 String data error

Generic string data error

–151 Invalid string data

An invalid string was received. Check to see if you have enclosed the character string in 
single or double quotes. 
Example; SYST:COMM:LAN:ADDR "10.0.0.2
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–158 String data not allowed

A character string was received but is not allowed for the command. Check the list of 
parameters to verify that you have used a valid parameter type. 
Example: SYST:LOCK 'ON'

–160 Block data error

Generic block data error

–161 Invalid block data

A block data element was expected but was invalid for some reason

–168 Block data not allowed

A legal block data element was encountered but not allowed by the 8990B at this point 

–170 Expression error

Generic expression error

–171 Invalid expression data

The expression data element was invalid

–178 Expression data not allowed

A legal expression data was encountered but not allowed by the 8990B at this point 
Example: MARK:LEV (5+5)

–200 Execution error

Generic syntax error

–210 Trigger error

An error occurred during triggering

–211 Trigger ignored

A triggering signal was received but the trigger was ignored 

–220 Parameter error

A data element related error occurred
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–221 Settings conflict;Requires channel # to be enabled

The channel selected is not enabled

–221 Settings conflict;Requires averaging to be enabled

The averaging mode is not enabled

–221 Settings conflict;Requires CCDF mode to be enabled

The data acquisition mode is not set to CCDF

–221 Settings conflict;Requires zoom mode to be enabled

The data acquisition mode is not set to zoom

–221 Settings conflict;Requires droop measurement to be enabled

The droop measurement is not enabled

–221 Settings conflict;Requires to switch to manual marker mode

The marker measurement mode is not set to manual

–221 Settings conflict;Requires to switch to pulse spacing marker measurement

The marker measurement mode is not set to pulse spacing

–221 Settings conflict;Requires CCDF sweep to be in free run mode

The CCDF sweep mode is not set to free run

–221 Settings conflict;Requires CCDF sweep to be in triggered mode

The CCDF sweep mode is not set to triggered

–221 Settings conflict;Requires CCDF trace # to be enabled

The CCDF trace from the channel selected is not enabled

–221 Settings conflict;Requires CCDF Gaussian trace to be enabled

The CCDF Gaussian trace is not enabled

–221 Settings conflict;Requires CCDF reference trace to be enabled

The CCDF reference trace is not enabled
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–221 Settings conflict;CCDF marker # source not set

The source of CCDF marker A or B is not set

–221 Settings conflict;CCDF source not set

The CCDF source is not set

–221 Settings conflict;Settings conflict;Fast trigger is only applicable to trigger source for 
channel 1 and 4. Fast trigger has been disabled

The fast trigger is enabled when the trigger source is set to channel 2, 3, or auxiliary

–221 Settings conflict;Unable to turn on video bandwidth while ETS mode is on

The video bandwidth is being turned on when the ETS mode is enabled

–221 Settings conflict;Unable to set video bandwidth to MEDIUM or HIGH. Frequency must be 
higher than 500 MHz

The video bandwidth is being set to medium or high when the frequency is less than 
500 MHz

–221 Settings conflict;Video bandwidth must be off when ETS is on. Video bandwidth is 
turned off

ETS is being turned on when the video bandwidth is enabled

–221 Settings conflict;Frequency less than 500 MHz. Video bandwidth has been set to LOW

The frequency is set to less than 500 MHz when the video bandwidth is set to medium or 
high

–221 Settings conflict;Unable to turn on Trigger on Event while ETS mode is on

The 8990B is set to trigger on event when the ETS mode is enabled

–221 Settings conflict;Trigger sweep must be in triggered mode while ETS is on. Trigger 
sweep is set to triggered mode

The trigger sweep mode is set to auto when the ETS mode is enabled

–221 Settings conflict;Unable to set trigger sweep to auto mode, time scale must be at least 
{0} or higher

The trigger sweep mode is set to auto when the time scale is too low
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–221 Settings conflict;No FDO data entry available

There is no data in the selected FDO table

–221 Settings conflict;No FDO table selected

There was no FDO table selected when sending an FDO table-related command

–221 Settings conflict;Duplicated frequency input

The frequency value specified for the FDO table is a duplicate of an existing frequency 
value

–221 Settings conflict;No data in waveform memory slot

There is no waveform data in the selected 8990B memory slot

–221 Settings conflict;Unable to set the trigger source. Command ignored

An error occurred when setting the trigger source

–222 Data out of range

A numeric parameter value is outside the valid range for the command 

Example: CHAN1:EXT 500

–222 Data out of range;Value clipped to minimum (#)

A numeric parameter value is lower than the minimum value allowed

–222 Data out of range;Value clipped to maximum (#)

A numeric parameter value is higher than the maximum value allowed

–223 Too much data

A data element was received that contains more data than the 8990B can handle

–224 Illegal parameter value

A discrete parameter was received which was not a valid choice for the command. You 
may have used an invalid parameter choice. 
Example: CHAN1:REF MIDD 

–225 Out of memory

The 8990B has insufficient memory to perform the requested operation



3 Maintenance

160 8990B User’s Guide

–231 Data questionable;Calibration error

8990B calibration and zeroing has failed

–231 Data questionable;Voltage overloaded

The voltage input to the channel exceeds the maximum range of the probe

–231 Data questionable;Calibration error in channel 1

An error has occured during calibration for channel 1

–231 Data questionable;Calibration error in channel 4

An error has occured during calibration for channel 4

–232 Invalid format

The data format or structure is inappropriate

–233 Invalid version

The version of the data format is incorrect

–240 Hardware error

The command could not be executed due to a hardware problem

–241 Hardware missing;Sensor not found in channel #

The 8990B is unable to execute the command because no sensor is connected to the 
respective channel

–250 Mass storage error

Generic error relating to mass storage

–251 Missing mass storage

The mass storage is not available

–255 Directory full

The specified directory is full

–256 File name not found

The selected file was not found
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–257 File name error

The file name is invalid

–260 Expression execution error

An expression program data element related error occurred

–291 Out of memory error

The memory is not sufficient to implement the command

–300 Device specific error

This is the generic device-dependent error for devices that cannot detect more specific 
errors. This code indicates that only a Device-Dependent Error as defined in the 
IEEE-488.2, 11.5.1.1.6 has occurred.

–310 System error

The 8990B operation has not completed properly, possibly due to an abnormal hardware 
or firmware condition

–311 Memory error

An error was detected in the 8990B memory

–330 Self-test failed

The 8990B self-test has failed

–340 Calibration failed

The 8990B calibration has failed

–350 Error queue overflow

The error queue is full and another error has occurred which could not be recorded

–400 Query error

Generic error query

–410 Query interrupted

A condition causing an interrupted query error occurred
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–420 Query unterminated

A condition causing an unterminated query error occurred

–430 Query deadlocked

A condition causing a deadlocked query error occurred

–440 Query unterminated after indefinite response

A query was received in the same program message after a query indicating an 
indefinite response was executed

700 Applicable to channel 1 and 4 only

A channel other than channel 1 or 4 has been specified for a command applicable for 
channels 1 and 4 only; or a command applicable for channels 1 and 4 only has been sent 
for a channel other than channel 1 or 4

701 Applicable to channel 2 and 3 only

A channel other than channel 2 or 3 has been specified for a command applicable for 
channels 2 and 3 only; or a command applicable for channels 2 and 3 only has been sent 
for a channel other than channel 2 or 3

702 Applicable to trigger source for channel 1, 4 and auxiliary only

A command applicable for the channel 1, 4, or auxiliary trigger source only has been sent 
when the trigger source was not set to any of these sources

703 Applicable in pair of channel 1 and 4 or 2 and 3

An incorrect channel pair has been specified

704 Applicable to trigger source for auxiliary only

A command applicable for the auxiliary trigger source only has been sent when the 
trigger source was not set to auxiliary

705 Applicable to trigger source for channel 1 and 4 only

A command applicable for the channel 1 or 4 trigger source only has been sent when the 
trigger source was not set to any of these sources

706 Applicable to trigger source for channel 2 and 3 only

A command applicable for the channel 2 or 3 trigger source only has been sent when the 
trigger source was not set to any of these sources
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720 No reference signal detected on the 10 MHz REF IN BNC input

There is no reference signal at the 10 MHz REF IN BNC input

780 System is busy, command unterminated

The system is busy processing the command

939 10 MHz setting is only applicable when ETS is off. 10 MHz setting is turned off

The ETS mode is set when the 10 MHz reference signal input is enabled

940 Unable to turn on 10 MHz setting when ETS is on

The 10 MHz reference signal input is being turned on when the ETS mode is enabled

943 Markers A and B are positioned on the same waveform

Markers A and B have to be placed on two separate waveforms to measure the time 
difference between them

946 Selected FDO table has reached the limit of 80 frequency points

Select another FDO table or delete some frequency points

977 Detected channel 1 frequency changed. Power level is questionable. Please zero and cal 
channel 1.

978 Detected channel 4 frequency changed. Power level is questionable. Please zero and cal 
channel 4.
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Recovering the 8990B Hard Drive

The 8990B hard drive recovery system is contained in a hidden partition 
on the 8990B hard drive. Using the 8990B hard drive recovery system will 
return the 8990B hard drive to the condition it was in when it left the 
factory.

Before recovering the 8990B hard drive, use the following procedure to 
return the 8990B to normal operation:

1 Turn off the 8990B.

2 Turn on the 8990B. If the 8990B does not successfully restart, then try 
recycling the power.

3 If the 8990B still does not successfully restart, follow the instructions 
below for recovering the hard drive.

8990B hard drive recovery

Use the following procedure to recover the 8990B hard drive:

1 Turn off the 8990B.

2 Connect the keyboard to the keyboard connector on the side panel of 
the 8990B.

3 Connect the mouse to the mouse connector on the side panel of the 
8990B.

4 Turn on the 8990B.

5 When you see the initial boot menu, select Agilent Recovery System and 
press Enter. Follow the on- screen instructions to complete the 8990B 
hard drive recovery process.



Maintenance 3

8990B User’s Guide 165

Removing the 8990B Hard Drive (Option 801)

This section explains how to remove the removable hard drive from the 
8990B Option 801. The hard drive is not required to be removed before 
sending the 8990B for calibration or service.

Use the following procedure to remove the 8990B removable hard drive.

1 Turn off the 8990B.

Figure 3-8 Turn off the 8990B

2 Unscrew the hard drive from the 8990B using a slotted screw driver as 
shown in Figure 3- 9.

Figure 3-9 Unscrew the hard drive
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3 Slowly pull and remove the hard drive from the slot in the 8990B.

Figure 3-10 Pull and remove the hard drive from the slot

4 To reinstall the hard drive, put the hard drive back into the slot and 
screw it onto the 8990B.

NOTE It is recommended to store the hard drive in an anti-static bag to prevent any damage to the 
hard drive.

CAUTION Ensure that you turn off the 8990B before removing or reinstalling the hard drive.
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Cleaning the 8990B

To clean the 8990B, disconnect its AC power cord and wipe the outer 
panels with a soft, lint- free, slightly water- dampened cloth. Do not use 
detergent.

Disassembly is not required or recommended for cleaning.

CAUTION Do not use too much liquid when cleaning the 8990B. Water can enter the front panel, 
damaging sensitive electronic components.
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Contacting Agilent

This section provides the information on what to do if you encounter 
problems with your 8990B.

First, refer to the section “Prior to contacting Agilent”. This section 
contains a checklist that helps identify some of the most common 
problems. 

If you wish to contact Agilent to enquire about the 8990B, from service 
problems to ordering information, refer to “Agilent Sales and Service 
Offices” on page 172.

If you wish to return the 8990B to Agilent, refer to “Returning the 8990B 
for Service” on page 171.

Prior to contacting Agilent

Before calling Agilent or returning the 8990B for service, perform the 
inspection based on the list in “Check the basics” on page 169. If you still 
encounter problems, read the warranty printed at the front of this guide. 
If your 8990B is covered by a separate maintenance agreement, familiarize 
yourself with the terms.

Agilent offers several maintenance plans to service your 8990B after 
warranty expiration. Call your Agilent Sales and Service Center for full 
details.
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Check the basics

Problems can be solved by repeating what was being performed when the 
problem occured. A few minutes spent in performing these simple 
inspections may eliminate time spent waiting for instrument repair. Before 
calling Agilent or returning the 8990B for service, make the following 
inspections:

• Check that the line socket has power.

• Check that the 8990B is plugged into a proper AC power source.

• Check that the 8990B is switched on.

• Check that other equipment, cables, and connectors are connected 
properly and operating correctly.

• Check the equipment settings in the procedure that was being used 
when the problem occurred.

• Check that the test being performed and the expected results are within 
the specifications and capabilities of the 8990B.

• Check the 8990B display for error indicators.

• Check the 8990B operation by performing the built- in self- test.

• Check using a different wideband power sensor.

Instrument serial numbers

Agilent makes frequent improvements to its products to enhance their 
performance, usability, and reliability. Agilent service personnel have 
access to complete records of design changes for each instrument. The 
information is based on the serial number and option designation of 
each 8990B.

Whenever you contact Agilent about your 8990B, have the complete serial 
number available. This ensures you obtain the most complete and accurate 
service information. The serial number can be obtained via the following 
methods:

• querying the 8990B over the remote interface using the *IDN? 
command.

• from the serial number label.
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The serial number label is attached to the rear panel of each Agilent 
instrument. This label has two instrument identification entries. The first 
provides the instrument serial number, and the second provides the 
identification number for each option built into the instrument.

The serial number is divided into two parts: the prefix (two letters and 
the first four numbers) and the suffix (the last four numbers). 

• The prefix letters indicate the country of manufacture. This code is 
based on the ISO international country code standard, and is used to 
designate the specific country of manufacture for the individual 
product. The same product number could be manufactured in two 
different countries. In this case, the individual product serial numbers 
would reflect different country of manufacture codes. The prefix also 
consists of four numbers. This is a code identifying the date of the last 
major design change.

• The suffix indicates an alphanumeric code which is used to ensure 
unique identification of each product throughout Agilent.

Figure 3-11 Serial number

Recommended calibration interval

Agilent recommends a one- year calibration cycle for the 8990B.

SERIAL NUMBER

SER MY12345678

OPT

Agilent MADE IN MALAYSIA
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Returning the 8990B for Service

Use the information in this section if you need to return your 8990B to 
Agilent.

Packaging the 8990B for shipment

Use the following procedure to package the 8990B for shipment to Agilent 
for servicing:

• Be as specific as possible about the nature of the problem. Send a copy 
of any or all of the following information:

• Any error messages that appeared on the 8990B display.

• Any information on the performance of the 8990B.

• Use the original packaging material or a strong shipping container made 
of double- walled, corrugated cardboard with 91 kg (200 lb) bursting 
strength. The carton must be large and strong enough to accommodate 
the 8990B and allow at least 3 to 4 inches on all sides of the 8990B for 
packing material.

• Surround the 8990B with at least 3 to 4 inches of packing material, or 
enough to prevent the 8990B from moving in the carton. If packing 
foam is not available, the best alternative is the SD- 240 Air CapTM from 
Sealed Air Corporation (Commerce, CA 90001). The Air Cap looks like a 
plastic sheet covered with 1- 1/4- inch air- filled bubbles. Use the pink 
Air Cap to reduce static electricity. Wrap the 8990B several times in the 
material as protection and to prevent it from moving in the carton.

• Seal the shipping container securely with strong nylon adhesive tape.

• Mark the shipping container as “FRAGILE, HANDLE WITH CARE” to 
ensure careful handling.

• Retain copies of all shipping papers.

CAUTION Damage to the instrument can result from using packaging material other than those 
specified. Never use styrene pellets of any shape as packaging material. They do not 
adequately cushion the instrument or prevent it from shifting in the carton. Styrene pellets 
cause instrument damage by generating static electricity and by lodging in the rear panel.
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Agilent Sales and Service Offices

In any correspondence or telephone conversations, refer to the 8990B by 
its model number and full serial number. With this information, the 
Agilent representative can quickly determine whether your unit is still 
within its warranty period.

Or visit Agilent’s Web site at www.agilent.com/find/assist.

UNITED STATES Agilent Technologies
(tel) (800) 829 4444

CANADA Agilent Technologies Canada Inc.
Test & Measurement 
(tel) (877) 894 4414

EUROPE Agilent Technologies
Test & Measurement 
European Marketing Organization
(tel) 31 20 547 2111

JAPAN Agilent Technologies Japan Ltd. 
(tel) 0120 (421) 345
(fax) 0120 421 678

LATIN AMERICA Agilent Technologies
Latin America Region Headquarters, USA
(tel) 305 269 7500

AUSTRALIA and 
NEW ZEALAND

Agilent Technologies Australia Pty Ltd. 
(tel) 61 3 9210 5555 (Australia)
(fax) 61 3 9210 5899 (Australia)
(tel) (408) 345 8886 (New Zealand)
(fax) (408) 345 8474 (New Zealand)

ASIA PACIFIC Agilent Technologies, Hong Kong
(tel) (852) 3197 7777 
(fax) (852) 2506 9292
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Introduction

This chapter details the 8990B specifications and supplemental 
characteristics.

Specification definitions

There are two types of product specifications: 

• Warranted specifications

• Characteristic specifications

Warranted specifications

Warranted specifications are covered by the product warranty and applied 
after a 30- minute warm- up. These specifications are valid over the 8990B 
operating and environmental ranges unless otherwise stated, and after 
performing zeroing.

Characteristic specifications

Supplemental characteristics which are specified in italics are intended to 
provide information useful in applying to the 8990B by giving typical, but 
non- warranted performance parameters. These characteristics are 
specified in italics or denoted as “typical”, “nominal”, or “approximate”.

Characteristic information is representative of the product. In many cases, 
it may also be supplemental to a warranted specification. Characteristic 
specifications are not verified on all products. The types of characteristic 
specifications can be placed in two groups: 

• The first group of characteristic types describes 'attributes' common to 
all products of a given model or option. 

Examples of characteristics that describe 'attributes' are product weight 
and 50 Ω input Type- N connector. In these examples, the product 
weight is an approximate value and the 50 Ω input is nominal. These 
two terms are most widely used when describing 'attributes' of a 
product.
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• The second group of characteristic types describes 'statistically' the 
aggregate performance of the population of products. 

These characteristics describe the expected behavior of the population 
of products. They do not guarantee the performance of any individual 
product. No measurement uncertainty value is accounted for in the 
specifications. These specifications are referred to as typical.

Conditions

The 8990B with a wideband power sensor meet its specifications when:

• stored for a minimum of two hours at a stable temperature within the 
operating temperature range, and turned on for at least 30 minutes.

• the 8990B and the wideband power sensor are within their 
recommended calibration periods.

• used in accordance to the information provided in this guide.
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Product Characteristics

POWER REQUIREMENTS

• 100 V to 120 V (50 Hz/60 Hz/400 Hz)
• 100 V to 240 V (50 Hz/60 Hz)
• Maximum power dissipated at 375 W

OPERATING ENVIRONMENT

• Operating temperature from 5 °C to 40 °C
• Relative humidity up to 95% at 40 °C (non-condensing)
• Operating altitude up to 4000 m (12000 ft)
• Operating random vibration at 5 Hz to 500 Hz, 10 min/axis, 0.21 g (rms)
• Pollution Degree 2:

Normally only non-conductive pollution occurs. Occasionally, however, a temporary 
conductivity caused by condensation must be expected.
Example: General indoor environment.

NON-OPERATING CONDITIONS

• Non-operating temperature from –40 °C to +70 °C
• Relative humidity up to 90% at 65 °C
• Non-operating altitude up to 4600 m (15000 ft.)
• Non-operating random vibration at 5 Hz to 500 Hz, 10 minutes/axis, 2.09 g (rms);

Resonant search at 5 Hz to 500 Hz, swept sine, 1 octave/minute, sweep rate at 0.5 g (0 peak),
5 minutes resonant, dwell at 4 resonance/axis

SAFETY COMPLIANCE

• IEC 61010-1:2001 / EN 61010-1:2001
• CAN/CSA-C22.2 No. 61010-1-04 
• ANSI/UL std No. 61010-1:2004 

DIMENSIONS (W × D × H)

430 mm (16.9 in) × 347 mm (13.7 in) × 330 mm (13.0 in)

WEIGHT

• <16 kg (net)
• <23.5 kg (shipping)

WARRANTY

3 years
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Specifications

Key system specifications

Average Power Measurement Accuracy[1]

• N1921A: ≤±0.2 dB or ≤±4.5%

• N1922A: ≤±0.3 dB or ≤±6.7%

• N1923A: ≤±0.2 dB or ≤±4.5%

• N1924A: ≤±0.3 dB or ≤±6.7%

RF input channels 2

Video input channels 2

Maximum real time sampling rate 100 MSa/s[1](Real Time), 1 GSa/s[1] (ETS On), 
and 20 GSa/s[2]

[1] For RF input channel 1 and 4

[2] For video input channel 2 and 3

Maximum capture length 1 s

Maximum memory depth 2 M points

Instrumentation linearity ±0.8%

Rise time/Fall time ≤5 ns (for frequencies ≥500 MHz)[3]

[3] Specifications applies only when the Off video bandwidth is selected

[1] Specification is valid over –15 to +20 dBm, and a frequency range 0.5 GHz to 10 GHz, DUT Max. SWR < 1.27 for the N1921A 
and N1923A, and a frequency range 0.5 GHz to 40 GHz, DUT Max. SWR < 1.2 for the N1922A and N1924A. Averaging set to 
32, in Free Run mode.
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Rise time percentage error

Although the rise time specification is ≤5 ns, this does not mean that the 
8990B and N1923/4A wideband power sensor combination can accurately 
measure a signal with a known rise time of 5 ns. The measured rise time 
is the root sum of the squares (RSS) of the signal under test rise time and 
the system rise time (5 ns).

Figure 4-1 Measured rise time percentage error versus signal under test rise time

Measured Rise Time SignalUnderTestRiseTime( )2
SystemRiseTime( )2+( )=

Measured rise time

percentage error
MeasuredRiseTime SignalUnderTestRiseTime–( )

SignalUnderTestRiseTime( )
--------------------------------------------------------------------------------------------------------------------------------------- 100×=
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Bandwidth

The video bandwidth in the peak power analyzer can be set to High, 
Medium, Low, and Off. The video bandwidths stated in the table below are 
not the 3 dB bandwidths, as the video bandwidths are corrected for 
optimal flatness (except the Off filter). Refer to Figure 4- 2 for information 
on the flatness response. The Off video bandwidth setting provides the 
warranted rise time and fall time specification and is the recommended 
setting for minimizing overshoot on pulse signals.

Figure 4-2 Flatness response

DYNAMIC RESPONSE — RISE TIME, FALL TIME, AND OVERSHOOT VERSUS VIDEO BANDWIDTH SETTINGS 

Parameter Video bandwidth setting

Low
5 MHz

Medium
15 MHz

High
30 MHz

Off

<500 MHz >500 MHz

Rise time/fall time[1] <60 ns <25ns <13 ns <50 ns ≤5.5 ns

Overshoot[2] <5% <5%

[1] Specified as 10% to 90% for rise time and 90% to 10% for fall time on a 0 dBm pulse. 

[2] Specified as the overshoot relative to the settled pulse top power.
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NOISE AND DRIFT

Sensor model Zeroing Zero set Zero drift[1] Noise/sample Measurement 
noise[2]

<500 MHz >500 MHz

N1923A/N1924A No RF input 200 nW 80 nW 3 μW 50 nW

RF present 550 nW 200 nW 80 nW 3 μW 50 nW

[1] Within 1 hour after a zero, at a constant temperature, after 24 hours warm-up of the peak power analyzer. 
This component can be disregarded with Auto-zero mode set to ON. 

[2] Measured over a 1 minute interval, at a constant temperature, two standard deviations, with averaging set to 1.

DYNAMIC RESPONSE — RISE TIME, FALL TIME, AND OVERSHOOT VERSUS VIDEO BANDWIDTH SETTINGS 

Video bandwidth setting

Low: 5 MHz Medium: 15 MHz High: 30 MHz Off

<500 MHz 0.91 1

>500 MHz 0.56 0.74 0.93 1

NOISE MULTIPLIER

Average setting 1 2 4 8 16 32 64 128 256 512 1024

<500 MHz 1.00 0.75 0.55 0.40 0.35 0.30 0.25 0.22 0.21 0.20 0.19

>500 MHz 1.00 0.73 0.52 0.37 0.28 0.21 0.17 0.15 0.14 0.14 0.14
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8990B specifications

RF INPUT (CHANNEL 1 AND 4)

Frequency range 50 MHz to 40 GHz

Dynamic range –35 dBm to +20 dBm

Measurement unit Linear (Watt) or Log (dBm), selectable

Video bandwidth 160 MHz[1]

Minimum pulse width 50 ns

Maximum pulse repetition rate 10 MHz

Input coupling 50 Ω

Vertical scale • 0.01 dB/div to 100 dB/div, 1-2-5 sequence or any 
arbitrary scaling, user defined

• 1 mW/div to 1 kW/div, 1-2-5 sequence or any 
arbitrary scaling, user defined

Offset ±99 dBm with 0.01 dB resolution

ETS threshold 500 ns, 1 μs, 2 μs, 5 μs, 10 μs

VIDEO INPUT (CHANNEL 2 AND 3)

Video bandwidth 1 GHz

Input impedance 50 Ω ±2.5%, 1 MΩ ±1% (11 pF typical)

Input coupling • 1 MΩ: AC (3.5 Hz), DC
• 50 Ω: DC

Vertical scale • 1 MΩ: 1 mV/div to 5 V/div, 1-2-5 sequence or any 
arbitrary scaling, user defined

• 50 Ω: 1 mV/div to 1 V/div, 1-2-5 sequence or any 
arbitrary scaling, user defined

DC gain accuracy ±2% of full scale at resolution on channel scale ±5 °C 
from calibration temperature

Offset accuracy ±(1.25% of channel offset + 1% of full scale + 1 mV) 
[2][3]

Maximum input voltage 1 MΩ: 150 VRMS or DC, CAT I
±250 V(DC + AC) in AC coupling
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Offset range

1 MΩ
1 mV to <10 mV/div

10 mV to <20 mV/div

20 mV to <100 mV/div

100 mV to <1 V/div

1 V to 5 V/div

50 Ω

±2 V

±5 V

±10 V

±20 V

±100 V

±12 div or ±4 V, whichever is smallest

TIMEBASE

Range 2 ns/div to 100 ms/div, 1-2-5 sequence or any arbitrary 
scaling, user defined

Delta time accuracy 1 ns + 0.02 × (time/div)

Timebase accuracy ±1.4 ppm peak

Channel to channel offset ±5 ns (ETS off), ±3 ns (ETS on)

Delay range ±1 s (maximum)

TRIGGER

Hardware Trigger

Sweep mode

Trigger mode

Trigger source

Auto, triggered

Positive and negative edge, pulse width (all channels)

Trigger by event (all channels)

Channel 1, 2, 3, 4, AUX

Trigger level

Level range

Channel 1 and 4

Channel 2 and 3

AUX

Level resolution

Channel 1 and 4

Channel 2 and 3

Level accuracy

Channel 1 and 4

–40 dBm to +20 dBm

±8 div from center screen (1 MΩ, edge mode)

TTL (high >2.4 V, low <0.7 V at 50 Ω)

0.01 dB

10 μV[4]

±0.5 dB (0.5 dB/ns slew rate in ETS mode)
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Trigger delay

Delay range

Delay resolution

±1 s (maximum)[5]

1% of the delay setting, 10 ns maximum (50 ns/div)

Trigger hold-off

Range

Resolution

1 μs to 1 s

1% of the selected value (to a minimum of 10 ns)

VERTICAL AND HORIZONTAL MARKERS

Resolution 1 ns (minimum)

SENSOR CHECK SOURCE

Frequency 1.05 GHz or 50 MHz (selectable)

Power level +0 dBm ±0.9% (50 MHz)

0 dBm ±1.2% (1.05 GHz)

Signal type Square pulse modulated (1.05 GHz only) or 
CW (1.05 GHz or 50 MHz)

Repetition rate 1 kHz

Connector type Type N (female)

SWR 1.05

WAVEFORM MEASUREMENT AND MATH

Pulse measurement Rise time, fall time, minimum, average, peak, 
peak-to-average, duty cycle, PRI, PRF, off time, pulse 
base, pulse top, pulse width, overshoot

Markers measurement Delay measurement, pulse space, pulse droop

Waveform math Add, averaging, common mode, divide, invert, magnify, 
multiply, PAE, PAE2, subtract, square, square root

Statistical CCDF (free run or triggered)

Video averaging 2, 4, 8, 32, 64, 128, 256, 512, 1024, 2048 (selectable)

Zoom Dual window zoom
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N6904A/8990B-1FP MULTIPULSE ANALYSIS SOFTWARE OPTION

Multipulse specifications

Maximum capture frame 

Minimum pulse to pulse duration 

Number of histogram bins 

Pulse to pulse measurement 

512 (each channel 1 and channel 4)

1 μs

20 (user-adjustable)

Compare any two pulses from the captured frames

SENSOR COMPATIBILITY

N1921A P-Series wideband power sensor, 50 MHz to 18 GHz

N1922A P-Series wideband power sensor, 50 MHz to 40 GHz

N1923A Wideband power sensor, 50 MHz to 18 GHz

N1924A Wideband power sensor, 50 MHz to 40 GHz

COMPUTER SYSTEM AND PERIPHERALS, I/O PORTS

Display 15-inch color XGA TFT-LCD with touchscreen 
capability

Computer system and peripherals

Operating system

CPU

System memory

Hard Drive

Peripherals

Windows 7 Embedded Standard

Intel Core 2 Duo CPU E8400 3 GHz microprocessor

4 GB

• ≥250 GB internal hard drive (option 800)
• ≥250 GB removable hard drive (option 801)
• Optical USB mouse and compact keyboard supplied
• Supports any Windows compatible input device 

with a PS/2 or USB interface

File types

Waveforms

Images

Comma Separated Values (*.csv)

BMP, TIFF, GIF, PNG, or JPEG

I/O ports

LAN RJ-45 connector, supports 10Base-T, 100Base-T, and 
1000Base-T. Enables web-enabled remote control, 
e-mail on trigger, data/file transfers, and network 
printing.
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RS-232 (serial)

PS/2

USB 2.0 Hi-Speed

Dual-monitor video output

Auxiliary output

Trigger out

Timebase reference output

Timebase reference input

COM1, printer, and pointing device support

Two ports. Supports PS/2 pointing and input devices.

• Three ports (front panel)
• Four ports (side panel)
• Allows connection of USB peripherals like storage 

devices and printing devices while the peak power 
analyzer is turned on. One device port on the side

15-pin XGA (side panel), full color output of the 8990B 
waveform display or dual monitor video output

DC (±2.4 V), square wave ~755 Hz with ~200 ps 
rise time

Output provides TTL compatible logic levels and uses a 
BNC connector

• 10 MHz, amplitude into 50 Ω, 800 mVpp to 12.6 Vpp 
(4 dBm ±2 dB) if derived from internal reference

• Tracks external reference input amplitude ±1 dB if 
applied and selected

10 MHz, input Z = 50 Ω
–2 dBm (minimum)

+10 dBm (maximum)

REMOTE PROGRAMMING

Interface

Command language

LAN and USB 2.0 interface

SCPI

[1] Video bandwidth tested by measuring peak-to-average on a two-tone separation signal at +10 dBm, 
frequency set at 1 GHz. Test limit set at 2 dB roll off from the nominal 3 dB peak-to-average flatness 
graph.

[2] 50 Ω input: Full scale is defined as 8 vertical divisions. Magnification is used below 10 mV/div, 
full-scale is defined as 80 mV. The major scale settings are 5 mV, 10 mV, 20 mV, 50 mV, 100 mV, 
200 mV, 500 mV, and 1V.

[3] 1 MΩ input: Full scale is defined as 8 vertical divisions. Magnification is used below 5 mV/div, 
full-scale is defined as 40 mV. The major scale settings are 5 mV, 10 mV, 20 mV, 50 mV, 100 mV, 
200 mV, 5 00 mV, 1 V, 2 V,and 5 V.

[4] The trigger level of analog channels is dependent on the vertical scale setting

[5] The trigger delay range is dependent on the timebase setting
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Regulatory Information

Electromagnetic (EM) compatibility

The 8990B complies with the essential requirements of the following 
applicable European (EC) Directives, and carries the CE marking 
accordingly to the Low Voltage Directive (2006/95/EC) and EMC Directive 
(2004/108/EC).

EMC tests conform to the IEC61326- 1:2005/EN61326- 1:2006 and CISPR 
11:2003/EN 55011:2007 (Group 1, Class A). In order to preserve the EMC 
performance of the 8990B, any cable which becomes worn or damaged 
must be replaced with the same type and specification.

The 8990B also meets the following EMC standards:

• Canada: ICES/NMB- 001: Issue 4, June 2006

• Australia/New Zealand: AS/NZS CISPR11:2004

Degradation of some instrument specifications can occur in the presence 
of ambient EM fields and noise that are coupled to the power line or I/O 
cables of the 8990B. The 8990B will self- recover and operate to all 
specifications when the source of ambient EM fields and noise are 
removed or when the 8990B is protected from the ambient EM fields or 
when the 8990B cabling is shielded from the ambient EM noise.

Product safety

The 8990B conforms to the requirements of the following safety standards:

• IEC 61010- 1:2001/EN 61010- 1:2001

• CAN/CSA- C22.2 No. 61010- 1- 04

• ANSI/UL std No. 61010- 1:2004

Low voltage directive

The 8990B conforms to the requirements of the European Council 
Directive "2006/95/EC".
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