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Upgrade Kit Model Number: N8983A 



WARRANTY STATEMENT

THE MATERIAL CONTAINED IN THIS DOCUMENT IS PROVIDED “AS IS,” AND IS SUBJECT TO BEING 
CHANGED, WITHOUT NOTICE, IN FUTURE EDITIONS. FURTHER, TO THE MAXIMUM EXTENT PERMITTED BY 
APPLICABLE LAW, AGILENT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED WITH REGARD TO 
THIS MANUAL AND ANY INFORMATION CONTAINED HEREIN, INCLUDING BUT NOT LIMITED TO THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. AGILENT SHALL 
NOT BE LIABLE FOR ERRORS OR FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH 
THE FURNISHING, USE, OR PERFORMANCE OF THIS DOCUMENT OR ANY INFORMATION CONTAINED 
HEREIN. SHOULD AGILENT AND THE USER HAVE A SEPARATE WRITTEN AGREEMENT WITH WARRANTY 
TERMS COVERING THE MATERIAL IN THIS DOCUMENT THAT CONFLICT WITH THESE TERMS, THE 
WARRANTY TERMS IN THE SEPARATE AGREEMENT WILL CONTROL.

DFARS/Restricted Rights Notice

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is 
delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as 
a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-
19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of 
Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments 
and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-
19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 
52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Safety Notes 

The following safety notes are used throughout this document. Familiarize yourself with each of these notes 
and its meaning before performing any of the procedures in this document. 

WARNING Warning denotes a hazard. It calls attention to a procedure which, if not correctly performed 
or adhered to, could result in injury or loss of life. Do not proceed beyond a warning note until 
the indicated conditions are fully understood and met.

CAUTION Caution denotes a hazard. It calls attention to a procedure that, if not correctly performed or 
adhered to, could result in damage to or destruction of the instrument. Do not proceed beyond a 
caution note until the indicated conditions are fully understood and met.
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Description of the Upgrade 

This upgrade kit changes the PNA operating system from Windows XP (32-bit) to Windows 7 (64-bit). For 
compatibility, some older N5242A models may require new touchscreen hardware (not included), and many 
PNA-X models may require a new CPU board assembly (included with N8983A-PC6). For more information, refer 
to “Before You Install This Upgrade Kit” on page 7. The N8983A-SP5 includes the current version of the SPAM 
board. 

User CalSets and Cal Registers that you want to keep must be converted in order to be read by Windows 7, as 
per “Step 4. Copy Any Existing Files You Want to Keep” on page 8.

Getting Assistance from Agilent

By internet or phone, get assistance with all your test and measurement needs.

Contacting Agilent

Assistance with test and measurements needs and information on finding a local Agilent office are available on 
the Web at:
http://www.agilent.com/find/assist

If you do not have access to the Internet, please contact your Agilent field engineer.

If You Have Problems With the Upgrade Kit Contents

Agilent stands behind the quality of the upgrade kit contents. If you have problems with any item in the kit, 
email Agilent Component Test Division (CTD) Support at support_ctd-soco@agilent.com, or telephone the CTD 
Hotline at (707) 577-6802 and leave a voice mail message. Please include details of the problem.
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Getting Prepared

CAUTION The PNA contains extremely sensitive components that can be ruined if mishandled. Please 
follow instructions carefully.

The person performing the work accepts responsibility for the full cost of the repair or 
replacement of damaged components.

To successfully install this upgrade kit, you will need the following:

• An ESD-safe work area - refer to “Protecting Your Workspace from Electrostatic Discharge” below.

• Enough time - refer to “About Installing the Upgrade” on page 5.

If you must replace the CPU board assembly (as described in “Step 2. If Necessary, Order a Replacement CPU 
Board Assembly” on page 7), you will also need the following:

• A PDF copy or a paper copy of the PNA Service Guide - refer to “Downloading the Online PNA Service 
Guide” below.

• Correct tools - refer to “Tools Required for the Installation” on page 5.

Downloading the Online PNA Service Guide 

To view the online Service Guide for your PNA model number, use the following steps:

1. Go to www.agilent.com.

2. In the Search box, enter the model number of the analyzer (Ex: N5232A) and click Search.

3. Click Technical Support > Document Library > Manuals.

4. Under the heading “By Type of Content,” click Service Manual.

5. Click the hyperlink of the service guide title to download the PDF file.

6. When the PDF of the Service Guide is displayed, scroll through the Contents section bookmarks to locate the 
information needed. 

Protecting Your Workspace from Electrostatic Discharge

For information, click on the Chapter 1 bookmark, “Electrostatic Discharge Protection” in the PDF Service 

Guide1.

ESD Equipment Required for the Installation

1. See “Downloading the Online PNA Service Guide” on page 4.

Description Agilent Part Number

ESD grounding wrist strap 9300-1367

5-ft grounding cord for wrist strap 9300-0980

2 x 4 ft conductive table mat and 15-ft grounding wire 9300-0797

ESD heel strap (for use with conductive floors) 9300-1308
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Tools Required for the Installation

No tools are required, unless the CPU board assembly is replaced (refer to “Step 2. If Necessary, Order a 
Replacement CPU Board Assembly” on page 7), in which case the Service Guide instructions list the tools 
required.

About Installing the Upgrade

Products affected................................................................ N522xA, N5231/2/4/5/9A, N524xA, and N5264A

Installation to be performed by Agilent Service Center 
or qualified personnel in ESD safe environment............ Solid State Drive (SSD) replacement

CPU Board Assembly replacement

Installation to be performed by Agilent Service Center 
only....................................................................................... Touchscreen hardware replacement

Converting and Saving User Calibration Files and Data 
Files........................................................................................ Allow up to 30 minutes

Estimated installation time.............................................. Solid State Drive replacement only: 5 minutes

CPU Board Assembly replacement: add 5 minutes

Touchscreen hardware replacement: add 2 hours

Estimated post-installation procedures time................. 5 minutes

SPAM board replacement: add 1 to 2 hours
Installation Note  N8983-90001                                                                                                                                      5



Items Included in the Upgrade Kit

Check the contents of your kit against the following list. If any part is missing or damaged, contact Agilent 
Technologies. Refer to “Getting Assistance from Agilent” on page 3.

Table 1 Contents of Upgrade Kit N8983A

Description Qty  Part Number

Installation note (this document) 1 N8983-90001

Solid state drive (SSD) for 2.0 GHz i7 CPU 1 N5242-60132

Windows 7 Certificate of Authenticity label 
(installed on SSD chassis next to thumbscrew)

1 N/A

Option PC6:

CPU board assembly, Intel ® 2.0 GHz Core ® i7 1 W1312-60196

Option SP5:

Signal Processing ADC Module (SPAM) board 5 (shield tabs removed) 1 N5240-60078

IF multiplexer board P603 to A16 SPAM board J2 1 N5247-60023

IF multiplexer board P203 to A16 SPAM board J5 1 N5247-60024
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Before You Install This Upgrade Kit

Step 1. If Necessary, Replace the Touchscreen Hardware for Early N5242A Models

If your N5242A PNA has a numeric serial number prefix below MY4822, SG4822, and US4812, and still has the 
original touchscreen, it will no longer be possible to calibrate the touchscreen after the upgrade. If this is a 
concern, return your PNA to Agilent to have the touchscreen and associated parts replaced. 

IMPORTANT Before returning your PNA to Agilent, complete steps 2, 3, and 4.

If accurate touchscreen operation is not a concern, keep your existing touchscreen, but make sure you calibrate 
it one last time before installing this upgrade kit.

Step 2. If Necessary, Order a Replacement CPU Board Assembly

If you purchased N8983A-PC6 or have an N522xA or N5231/2/4/5/9A PNA model, you do NOT need to order a 
new CPU board assembly. Proceed to Step 3.

For N524xA and N5264A models, only CPU part number W1312-60196 is compatible with this upgrade kit. This 
is included with N8983A-PC6.

If you have an N524xA, or N5264A PNA model, you must verify that your CPU board assembly part number is 
W1312-60196. On the rear panel of the PNA, locate the assembly containing the LAN and USB ports - this is the 

CPU assembly. A label1 below the USB ports contains the CPU board assembly part number. If you have a 
different part number, and you did not order N8983A-PC6, contact Agilent to order part number W1312-60196. 

IMPORTANT If you choose to have Agilent Service Center personnel replace your CPU board assembly, 
instruct them NOT to install an SSD in the assembly. You will install the SSD shipped with this 
upgrade kit in your new CPU board assembly.

Step 3. If Necessary, Download PNA Firmware for Your Existing Windows XP Drive

Before you install this upgrade kit, it is strongly recommended that you have firmware revision A.09.90.05 (or 
later, but within the A.09.90.xx range) installed in your PNA. If already installed, proceed to Step 4.

Windows XP and the Windows 7 drives require the PNA internal flash memory to have different formats. PNA 
firmware revision A.09.90.08 (or later, but within the A.09.90.xx range) and Windows 7 can recognize both 
formats and act accordingly. 

If older PNA firmware is installed and the old Windows XP drive is reused after this upgrade kit is installed, the 
PNA will not function, errors will be generated, and the current contents of the flash memory will be corrupted, 
making any recovery extremely difficult.

To learn which firmware revision is currently loaded in your PNA, press Help > About Network Analyzer. In the 
window displayed, find “Application Code Version.”

1. If the label is missing, you can learn your System CPU version using the PNA software. On the PNA front panel, press Help 
> About Network Analyzer. In the window displayed, find “System CPU Version.” If the value is below 6.0, you must replace 
your CPU board assembly. Contact Agilent to order part number W1312-60196.
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Download firmware at no charge at: http://na.tm.agilent.com/pna/firmware. 

Step 4. Copy Any Existing Files You Want to Keep

Upgrading to Windows 7 will not affect the PNA calibration or any installed permanent options, however all 
temporary options will be lost. If the loss of temporary options is an issue, then print or copy the text file gen.lic 
to some other media so that the keywords can later be reinstalled on the Windows 7 drive. This file is located in 
C:\Program Files\Agilent\Network Analyzer. You may also want to copy other existing files from your XP drive 
to some other media before you install the Windows 7 drive. The following table lists the locations where these 
files can be found on the XP drive and where they should be located on the Windows 7 drive.

IMPORTANT User CalSets and Cal Registers cannot be copied to the new drive. Any User CalSets and Cal 
Registers you want to keep must be converted to “.cal” or “.csa” files. To do this, each one must 
be recalled using File > Recall and stored as a “.cal” or “.csa” file using File > Save As. For 
more information, read “Save and Recall a File” in PNA Help.
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Table 1 Files to Copy Before Installing the Windows 7 Drive

File Type Location on Windows XP 
Drive

Location on Windows 7 Drive Notes

State Files (.csa, 
.cst, .sta, .cal)

C:\Program 
Files\Agilent\Network 
Analyzer\Documents

C:\Users\Public\Documents\
Network Analyzer

Copy from XP location to Win7 
location

Result Files (.snp, 
.csv, .cti)

C:\Program 
Files\Agilent\Network 
Analyzer\Documents

C:\Users\Public\Documents\
Network Analyzer

Copy from XP location to Win7 
location

Mixer Files 
(.mxr, mxrx)

C:\Program 
Files\Agilent\Network 
Analyzer\Mixer

C:\Users\Public\Documents\
Network Analyzer\Mixer

Copy from XP location to Win7 
location

Device Driver 
Files for DC or 
Generic Sources

C:\Program 
Files\Agilent\Network 
Analyzer\Drivers

C:\Users\Public\Documents\
Network Analyzer\Drivers

Copy from XP location to Win7 
location

Disk Based ECal 
User 
Characterization 
Files (.euc)

C:\Program 
Files\Agilent\Network 
Analyzer\ECal User 
Characterizations

C:\Users\Public\Documents\
Network Analyzer\ECal User 
Characterizations

Copy from XP location to Win7 
location

Noise ENR Files 
(.enr)

C:\Program 
Files\Agilent\Network 
Analyzer\Documents\Noise

C:\Users\Public\Documents\
Network Analyzer\Noise

Copy from XP location to Win7 
location

User Cal Kits 
(.wks)

C:\Program 
Files\Agilent\Network 
Analyzer\PnaCalKits\User\
userkits_7.50.wks

Hidden Folder In the Win7 PNA, use the 
“Open...”button at the top of 
the Edit Cal Kits dialog to 
browse to the “.wks” file you 
copied from your Windows XP 
drive. Select the “*.wks” file 
type filter in the drop-down 
menu. Select your “.wks” file 
to load all your cal kits.

Color Scheme C:\Program 
Files\Agilent\Network 
Analyzer\Documents\Colors

C:\Users\Public\Documents\
Network Analyzer\Colors

Copy from XP location to Win7 
location
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Upgrade Procedure

NOTE The network analyzer must be in proper working condition prior to installing this option. Any 
necessary repairs must be made before proceeding with this installation.

1. Confirm that you have the correct touchscreen display installed – for information, refer to “Step 1. If 
Necessary, Replace the Touchscreen Hardware for Early N5242A Models” on page 7.

2. Confirm that you have the correct CPU board assembly installed in your PNA, or that you have received a 
new CPU board assembly, either in the N8983A-PC6, or shipped from Agilent Support Parts Organization 
(SPO). 
If you must replace the CPU board assembly, follow the instructions in “Removing and Replacing the CPU 
Board Assembly,” located in chapter 7 of the Service Guide.

3. If you purchased N8983A-SP5: 

a. Install the new SPAM board. Refer to the instructions located in chapter 7 of the Service Guide.

b. If your PNA is a 2-port model, replace two flex cables with those included in the kit. See the cable 
descriptions in “Items Included in the Upgrade Kit” on page 6 of this document. For a graphic showing 
cable locations, refer to the chapter 6 of the Service Guide.

4. Replace the Windows XP drive with the new Windows 7 drive included in this upgrade kit using the 
following instructions. If you have not done this before, or you want to see a graphic, refer to “Removing and 
Replacing the Hard Disk Drive (HDD),” located in chapter 7 of the Service Guide.

a. Power off the PNA. 

b. Remove all USB devices except the mouse and keyboard from the PNA.

c. Remove the power cord from the PNA.

d. Loosen the thumbscrew on the installed SSD and remove the SSD from the drive bay of the CPU board 
assembly.

e. Insert the new, supplied SSD into the drive bay of the CPU board assembly and hand tighten the 
thumbscrew on the SSD.

f. Reinsert the power cord to the PNA.

g. Verify that there are no USB devices connected to the PNA except a mouse and keyboard.

h. Power on the PNA.

5. The PNA will go through its initialization process. This will take about 10 minutes and may involve as many 
as five reboots. Do not proceed until all activity has stopped.

6. The touchscreen will likely be uncalibrated and reversed left-to-right – this is normal. Calibrate the 
touchscreen by pressing System > Touchscreen > Calibrate Touchscreen. Follow the instructions 
displayed.

7. If desired, copy any files you saved earlier to their new locations on the Windows 7 drive - see Table 1 on 
page 9.

8. Set aside the old Windows XP drive (and CPU board assembly, if replaced) in case you later discover you 
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need a file from the old drive.

NOTE If, after you install the Windows 7 drive, you need to access some files on the old XP drive, use a 
USB 2.5-inch hard drive enclosure. These are inexpensive and are very simple to use. Just make 
sure you get an enclosure that matches your existing hard drive interface – either SATA (slide-in 
drive) or PATA (internal drive).

9. The PNA does not come with any antivirus software installed. You may want to install an antivirus program 
before connecting the PNA to the Internet. You may also want to download and install any recent Windows 
Updates.

10. This upgrade kit contains PNA firmware revision A.10.00.xx. You may want to verify that this is the most 
recent firmware revision available for Windows 7 at: http://na.tm.agilent.com/pna/firmware.

11. The upgrade is now completed, and the PNA is ready for use.

NOTE You may notice that the Windows User Access Control (UAC) will prompt you for permission to 
install programs or make other critical changes. While this feature can be turned off, this is not 
recommended due to security concerns

NOTE Firmware for Windows 7 will always be A.10.00.00 or higher. Firmware for Windows XP will 
always be below A.09.99.99. You cannot run firmware below A.10.00.00 on a Windows 7 PNA. 
Likewise, you cannot run firmware A.10.00.00 or above on a Windows XP PNA.

NOTE For many years now, the administrator user name has been “pna-admin” and the password has 
been “agilent”. In Windows 7, the user name will remain the same, but the password has 
changed. All PNAs with Windows 7 will use the default lower-case password of “pna”. If the 
short length violates your company policy, it can be lengthened.

NOTE The Windows Properties dialog box (to access, right-click Computer, then click Properties) does 
not indicate Windows 7. Instead, it shows “Windows Embedded Standard.” This is Windows 7 
made specifically for embedded systems such as the PNA.
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