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Self-Guided Demonstration

Option BHB Multiband-OFDM Modulation Analysis
89600 Vector Signal Analysis Software

Beginning with release 16 .0 of the 89600 VSA software,  
Option BHB ( UWB Modulation Analysis) will be 
discontinued . 
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WiMedia Alliance Ultra-Wideband Physical Layer Overview

The WiMedia® Alliance defines and 
supports the ultra-wideband (UWB) 
common radio platform, which is 
designed for use in wireless personal 
area networks (WPAN) . The standard 
defined by the WiMedia Alliance 
defines the physical (PHY) and media 
access control (MAC) layers for the 
UWB common radio platform . The 
specification published by the WiMedia 
Alliance is the WiMedia PHY Test 
Specification . The ISO specifications 
that are based on the WiMedia 
Alliance specification are ECMA-368 
and ECMA-369 . 

Certified Wireless USB is an extension 
to existing wired USB that uses the 
WiMedia UWB common radio platform . 

It will provide the functionality of 
existing USB but will do so without the 
need for wires, at target data rates of 
480 Mb/s at 3 meters, and 110 Mb/s 
at 10 meters . Certified Wireless  
USB will initially be employed by 
consumer electronic devices, PC 
peripherals, and mobile devices .

The specification promoted by the 
WiMedia Alliance is based  
on Multiband Orthogonal Frequency 
Division Multiplexing (MB-OFDM) . It is 
one of the two proposals that were 
presented to the IEEE working group 
802 .15, task group 3a (802 .15 .3a) . The 
supporting organizations behind each 
of the two proposals now continue to 
promote them outside of the IEEE task 

group . This is done through the WiMedia 
Alliance, for MB-OFDM based UWB, 
and the UWB Forum, for Direct 
Sequence UWB (DS-UWB) . This 
technical overview will focus on the 
PHY layer of MB-OFDM UWB .

The ECMA-368 standard specifies 
UWB operation in the frequency range 
of 3 .10 to 10 .60 GHz, for unlicensed 
operation . In this range are 14 bands, 
each 528 MHz wide . The lower (in 
frequency) 12 bands are grouped into 
four groups of three bands each, and 
the upper two of the 14 bands are 
grouped into a fifth group . The sixth 
band group consists of bands 9 to 11, 
which overlap band groups 3 and 4 .  
For any one symbol transmitted, the 

Figure 1. Frequency band plan for UWB band groups.
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WiMedia Alliance Ultra-Wideband Physical Layer Overview (continued)

Figure 2. Example TFC hopping sequences.

Magnitude

–61 to –1 +1 to +61

122 Useful subcarriers

128 Overall subcarriers

Freq

3168 MHz 3432 MHz 3696 MHz

Null subcarriers (6)

Data subcarriers (100)

Guard subcarriers (10) (±61 to ±57)

Plot subcarriers (12) (±55, ±45, ±35, ±25, ±15, ±5)

Figure 3. Frequency-domain structure of UWB OFDM signal.

occupied bandwidth of the signal is 
nominally 528 MHz . However, the 
signal may hop in frequency according 
to predetermined patterns referred to as 
Time-Frequency Codes (TFCs) . Certain 
TFCs have the signal hop to a different 
center frequency on every symbol . The 
data rates of devices that conform to 
the standard are from 53 .3 Mb/s to 
200 Mb/s, with data rates above 200 
Mb/s being optional .

In the 528 MHz bandwidth signal, the 
OFDM structure is as follows . The 
signal has a total of 122 useful 
subcarriers, with a spacing of 4 .125 MHz 
between each . Ten of the subcarriers 
are guard subcarriers; five are on the 
lower-frequency edge of the signal, 
and five are on the upper-frequency 
edge of the signal . The guard subcarriers 
are implemented to ensure compliance 
with regulatory conditions such as 

minimum occupied bandwidth, and 
their power levels are adjusted 
accordingly . Twelve pilot carriers are 
distributed in frequency within the 
signal . Their locations in the frequency 
domain are defined in the standard 
(see Figure 3) and do not change from 
symbol to symbol . The remaining 100 
subcarriers are data-bearing .



4

WiMedia Alliance Ultra-Wideband Physical Layer Overview (continued)

The MB-OFDM standard allows for 
several modulation schemes to 
transmit data over the 100 data-bearing 
subcarriers . QPSK modulation is used 
on the subcarriers for data rates up to 
200 Mb/s, with different coding rates 
used to achieve different data rates . 
For the 320 Mb/s, 400 Mb/s, and  
480 Mb/s data rates, a dual-carrier 
modulation (DCM) scheme is 
employed . DCM is a technique where 
bits are organized into groups of four . 
Each group of 4 bits is then mapped 
onto two separate constellation maps . 
Their structure is very similar to a 
16QAM constellation . Each 16QAM 
constellation is then modulated onto 
two subcarriers, with one subcarrier 
located 50 subcarriers away from the 
other . Since subcarriers with this 
separation are approximately 206 MHz 
apart, the probability that both points 
will suffer from fading simultaneously is 
reduced, and diversity loss is reduced .

As with many other OFDM-based 
technologies, UWB mitigates effects  
of multi-path interference through the 
use of padding and extending . Instead 
of using symbol padding, however, zero 
padding is used . The IFFT and FFT 
period of a symbol is 242 .42 ns long, 
and the zero-padded suffix is 70 .08 ns 

long . Thus, the total symbol length is 
312 .5 ns . In addition to minimizing  
the effects of multi-path interference, 
the zero-padded suffix allows the 
transmitter and receiver some time to 
switch between the hopped center 
frequencies of the TFC employed . 

From a frame structure perspective, 
MB-OFDM UWB is similar to other 
wireless networking formats . The 
general physical layer frame contains  
a preamble, a header, and a payload 
(see the Timing Diagram on page 26) . 
The preamble, or PLCP Preamble, 
provides timing synchronization and 
channel estimation . A standard 
preamble or a shorter burst preamble 
may be used . The header, or PLCP 
header, contains information such as 
the rate and length of the payload to 
follow, the MAC header, and tail and 
parity bits . The header is always sent 
at 39 .4 Mb/s, regardless of the data 
rate of the payload . The payload, or 
PSDU, contains the frame payload, of 
variable length, and check and pad 
bits . Its data rate can vary among the 
values mentioned above .

The standard PLCP preamble is used 
by the receiver for packet/frame 
synchronization and channel estimation . 

Packet/frame synchronization provides 
coarse frequency estimation of the 
carrier and coarse symbol timing; the  
channel estimation portion of the 
preamble provides fine estimation of 
the carrier frequency, symbol timing, 
and frequency response of the channel . 
The burst preamble is used in a 
streaming mode, where bursts of 
packets are sent consecutively, 
separated only by a short time interval, 
known as the minimum inter-frame 
separation time (pMIFS) . The structure 
of the burst preamble is identical to the 
structure of the standard preamble:  
a packet/frame synchronization part 
followed by a channel estimation part . 
The packet/frame estimation portion 
of the burst preamble is half as long as 
the equivalent portion in the standard 
preamble . The channel estimation 
portions of the burst and standard 
preambles are of the same length .

The MB-OFDM standard continues to 
evolve in consideration of new data 
rates and interference mitigation . 
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Adopting the Best Measurement Approach

The 89600 VSA software, with 
Multiband-OFDM Modulation  
Analysis, is ideal for the analysis and 
troubleshooting of the complex, wide-
bandwidth, and time-varying nature of 
UWB MB-OFDM signals . Combined 
with Infiniium oscilloscopes, it covers 
all frequency ranges as defined by  
the WiMedia Alliance standard . It can 
also analyze and demodulate signals 
modulated with any of the ten possible 
TFCs over any of the band groups, with 
automatic or manual TFC detection . 
The mandatory data rates, as well as 
the optional higher data rates, are 
supported, allowing the designer to 
test the maximum throughput of the 

device, up to 480 Mb/s . For these 
higher data rates, modulation analysis of 
DCM and the use of burst preambles are 
supported . If the system or device under 
test is a non-hopping MB-OFDM signal, 
it can be examined by de-selecting 
Frequency Hopping Analysis on the 
Advanced tab of the DemodProperties 
dialog box . Other useful Advanced tab 
troubleshooting capabilities include 
analyzing time-scaled baseband 
signals that are hopped at final 
frequencies .

When measuring and troubleshooting 
digitally modulated systems, it is  
tempting to go directly to digital 

demodulation and the measurement 
tools . It is usually better to follow  
a measurement sequence: one  
that begins with basic spectrum 
measurements and continues with 
vector (combined frequency and time) 
measurements before switching to 
basic digital modulation analysis and 
finally to advanced and/or standard 
specific analysis . This sequence of 
measurements is especially useful 
because it reduces the chance that 
important signal problems will 
be missed .

1 Spectrum and time domain measurements
Get basics right, find major problems

2 Basic digital demodulation
Signal quality numbers, constellation, basic error vector measurement

3 Advanced digital demodulation
Find specific problems and causes

Figure 4. Measurement and troubleshooting sequence used in this guide.

Step 1: Spectrum and time domain 
measurements
These measurements evaluate the 
basic parameters of the signal, the 
parameters that must be correct for 
demodulation to take place . Parameters 
such as center frequency, bandwidth, 
symbol timing, power, and spectral 
characteristics are investigated .

Step 2: Basic digital demodulation
These measurements evaluate the 
quality of the constellation . Along with 
a display of the constellation, they 
include static parameters such as: 
EVM, I/Q offset, frequency error, and 
symbol clock error .

Step 3: Advanced digital demodulation
These measurements are used to 
investigate the causes of errors 
uncovered in the basic modulation 
parameters, particularly EVM errors . 
These include dynamic parameters 
such as: Error vector frequency, error 
vector time, and pilot phase error .
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Setting Up the Demonstration

Table 1. System requirements

The 89600 VSA software requires a PC connected via USB, GPIB or LAN I/O to a supported Agilent platform, including oscilloscopes, logic 
analyzers, and simulation software . For a list of supported platforms, see the Hardware Measurement Platforms Data Sheet, 5989-1753EN .
To run the demonstration, either a laptop or desktop PC may be used as long as it meets or exceeds the following minimum requirements . 
In addition, you may run this demonstration in the supported oscilloscope itself: 1

Operating system Microsoft® Windows® XP Professional,  Microsoft® Windows® Vista Business,   
 Service Pack 2 Enterprise, or Ultimate

CPU > 1700 MHz Pentium® or 1 GHz 32-bit (x86) 
 AMD-K6® > 2 GHz recommended > 2 GHz recommended

RAM 512 MB  1 GB
 1 GB recommended for oscilloscopes  2 GB recommended for oscilloscopes
 with optional memory  with optional memory

Video RAM 4 MB (16 MB recommended) 125 MB (512 MB recommended)

Hard disk space 512 MB available 512 MB available

Additional drive CDROM to load the software; license transfer  CDROM to load the software; license transfer  
 requires 3 .5-inch floppy drive, network access,   requires 3 .5-inch floppy drive, network access,   
 or USB memory stick  or USB memory stick

Interface support LAN, GPIB, or USB LAN, GPIB, or USB

1   For best immunity from electrostatic discharge (ESD), use a desktop PC .

Table 2. Software requirements

Version 89600 v10 .0 required for full functionality described

Options (89601A, 89601AN only) 
 - 200 Basic vector signal analysis 
 - 300 Hardware connectivity (required only if measurement hardware will be used) 
 - BHB Multiband-OFDM modulation analysis
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Setting Up the Demonstration (continued)

Table 3. Frequency and time domain setup
Instructions Navigation
Preset the analyzer Click File > Preset > Preset All 
 Note: Using Preset All will cause all saved user  
 state information to be lost . If this is a concern,  
 save the current state before using Preset All .  
 Click File > Save > Setup 
 Note: The Menu/Toolbars, Display Appearance,  
 and User Color Map may also be saved in a  
 similar way .
Recall the simulated UWB  Click File > Recall > Recall Recording 
MB-OFDM signal  Navigate to the directory which contains the  
MBOFDM_TFC6_480Mbs .sdf signal C:\Program Files\Agilent\89600 VSA\ 
 Help\ Signals\ MBOFDM_TFC6_480Mbs.sdf
Begin replay of the recording Click Control > Restart 
 Or, alternatively, click     (toolbar, left side)
Notes 
 
The size of the display window can be changed as desired . It may be useful to enlarge the 
display window (click and drag, as with any standard window) to see fine structure in a 
time domain or frequency domain display . 
 
Start the measurement Click Restart (    toolbar, left side) 
  . . .the analyzer will playback and measure the  
 signal, starting at the beginning of the recording  
 each time Restart is clicked .  
 Note: The analyzer defaults to the span used to  
 record the signal, and an overlap (governs the  
 speed of signal playback) of 90% . 
 
Temporarily halt playback Click Pause (II toolbar, left side) 
 Click it again to resume playback from the point  
 where it was paused 
 
If you wish to see what portion of the recording is currently selected for analysis, you can 
bring up the player window by selecting Control > Player . This window provides both a 
graphical and numeric indication of the current analysis location in the recording .



8

Self-Guided Demonstration
Spectrum and time domain measurements

1 Spectrum and time domain measurements
Get basics right, find major problems

2 Basic digital demodulation
Signal quality numbers, constellation, basic error vector measurement

3 Advanced digital demodulation
Find specific problems and causes

The analyzer defaults to a stacked 2-
trace display where the top trace  
is a spectrum measurement and the 
bottom trace is a time domain 
measurement, as shown in Figure 5 .  
The default for the bottom trace is a 
vertical axis indicating logarithmic 
signal magnitude (envelope of the 
signal) . The RF bursts in this signal can 
be seen as the recording is played back . 
The triggering defaults to the free run 
mode, so the signal will simply play 
back as it was originally recorded . The 
signal is centered at 3 .96 GHz, and the 
1 .6 GHz span clearly shows the entire 
528 MHz-wide signal .

Triggering properly gives the user a 
stable signal to work with, and once the 
signal is properly centered on screen, 
and properly triggered, accurate and 
repeatable measurements can be made .

Table 4. Setting the trigger
Instructions Navigation
Select the trigger type Click Input > Playback Trigger 
 Select Channel from the Type drop-down menu 
 Note: The playback is limited to recorded signals .  
 To trigger live signals, use an external trigger or  
 pulse search . The pulse search is the most robust  
 method when the input is from hardware rather  
 than from a recorded signal .
Set the trigger level Type 70 mV in the Level field 
 Click OK to accept 
  . . .a dotted line will appear on the trace at the  
 programmed trigger level
Set the hold-off style Select Below Level  
 Note: Below Level hold-off style is the appropriate
 trigger type for high duty cycle bursts . For live 
 signals, its applicability may be limited by the
 specific hardware you are using to make
 measurements
Set the hold-off time Type 2 µsec in the Hold-off field 
 Click OK to accept
Set the trigger delay value Type –10 µsec in the Delay field 
 Click OK to accept
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Self-Guided Demonstration (continued)
Spectrum and time domain measurements

The signal may be easier to see clearly 
if auto-scale is used on the spectrum 
trace . Activate auto-scale by right-
clicking the upper trace and selecting 
Y Auto Scale with either mouse 
button . Do this for both trace A and  
trace B .

To increase the resolution of the traces, 
increase the number of points in the 
record to increase the time record length .

Table 5. Changing the number of frequency points
Instructions Navigation
Select a larger number of  Click MeasSetup > ResBW 
frequency points Select 102401 from the Frequency Points  
 drop-down menu 
 Note: Increasing the number of frequency points  
 increases the time record length while maintaining  
 the frequency span; for more information on time  
 record go to Help > Content > Index and type  
 Time Record Length .

Set resolution bandwidth to 100 kHz Type 100 kHz in ResBW field

Figure 5. A properly triggered signal shows the spectrum and time displays of the 
signal, including the on-time and off-time.
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Self-Guided Demonstration (continued)
Spectrum and time domain measurements

Spectrum measurements

The signal is centered at 3 .96 GHz with 
an actual bandwidth of 507 .4 MHz (122 
x 4 .125 MHz + 4 .125 MHz for carrier 0) . 
The occupied bandwidth (OBW) marker 
calculates these values from the 
spectrum trace . The bottom of the 
window will show the results of the 
OBW marker:  the occupied bandwidth, 
centroid, and offset from trace center 
frequency .

The power in the occupied band is 
calculated by the band power marker . 
Once the measurement is enabled, a 
shaded portion of the spectrum will 
indicate the region used to calculate 
the band power . The measurement 
result, in dBm, will be displayed in the 
marker annotation area at the bottom  
of the screen . Note that the bandpower 
marker power should match the power 
listed in the summary OBW table in 
trace B .

To deactivate the OBW measurements, 
simply right-click the spectrum trace 
and clear the OBW marker . Using the 
trace B trace title hot-spot, return  
trace B to Main Time . Hot-spots exist 
anywhere on the display that a cursor 
changes to a hand icon . To use them, 
double click the parameter you want to 
change while this cursor is displayed .

Table 6. Measuring the occupied bandwidth and band power
Instructions Navigation
Enable the OBW measurement  Right-click trace A 
on the trace of interest Select Show OBW
Display the power of the  Select trace B by left-clicking anywhere in the  
occupied bandwidth trace  
 Select Trace > Data > Marker >  
 Obw Summary TrcA on trace B
Select the center point of the  Right-click trace A 
band power measurement Select Show Band Power 
  . . .this readies the cursor to select the center of the  
 band power measurement 
 Click a point at the center frequency of the signal  
 in trace A
Stretch the width of the region of  Click and drag either of the two vertical bars on  
the band power measurement so  the edge of band power region and stretch it so it  
that it overlaps the shaded region  overlaps the shaded OBW region 
of the OBW measurement
Once finished with the measurement,  Right-click trace A 
turn off the OBW and band power  Clear Show OBW 
measurements Right-click trace A 
 Clear Show Band Power
Display the time trace again Left-click on trace B 
 Select Trace > Data > Main Time

Figure 6. The occupied bandwidth marker’s results are shown at the bottom of 
the window.
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Self-Guided Demonstration (continued)
Spectrum and time domain measurements

Measuring the symbol time

Time-domain measurements help 
verify transmitter characteristics such 
as on and off times, rise and fall times, 
and other parameters . Changing the 
time length allows the user to zoom in 
the time-domain to areas of interest .

The symbol time can be measured with 
markers . The symbol time is measured 
by placing a marker on the rising edge of  
a symbol, and an offset marker on the  
rising edge of the symbol immediately  
following it . The marker readout at the 
bottom of the screen will show the 
differences in time and amplitude 
between the two markers, and, in this 
case, will report the total symbol time 
for one symbol, also referred to as TSYM .

Table 7. Changing the time length
Instructions Navigation
Change the time length to a  Click MeasSetup > Time 
smaller value to see details in  Type 1 µsec in the Main Time Length field 
the time domain  . . .the main time display shows approximately  
 three symbols

Table 8. Measuring the symbol time
Instructions Navigation
Pause the recording to more easily  Click II at the top left corner of the window 
make the measurement
Place a marker on the main  Right-click the main time measurement (trace B) 
time trace Select Show Offset 
  . . .this places a marker and an offset in the display
Place the marker on the rising edge  Click a portion of the trace that shows the rising  
of a symbol edge of a symbol
Move the offset marker to the  Right-click the screen 
location of the reference marker Select Move Offset to Mkr
Place the marker on the adjacent  Click the rising edge of the next symbol on the  
symbol’s rising edge trace 
  . . .the offset marker will remain where it is 
 Note: The offset marker data is shown in the marker  
 annotation area at the bottom of the window .
Once finished with the measurement,  Right-click trace B 
turn off the markers Clear Show Marker
Resume playing the recording Click     to resume replay

Figure 7. Measurement of one symbol-time using markers.
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Self-Guided Demonstration (continued)
Spectrum and time domain measurements

The spectrogram is a three-
dimensional display that shows the 
changes in signal spectrum over time . 
It is particularly useful when analyzing 
signals that are bursted or frequency 
hopping, as are UWB signals . Features 
of signal transients, OFDM signal 
structure, and spectral splatter can all 
be identified with this display .

Table 9. Changing the time length
Instructions Navigation
Select a smaller number of  Click MeasSetup > ResBW 
frequency points Select 6401 from the Frequency Points  
 drop-down menu 
 Note: Reducing the number of frequency points  
 will reduce the processing needed to display the  
 spectrogram .
Switch to a single display format Click Display > Layout > Single 
  . . .this will allow the spectrogram display to fill the  
 entire usable portion of the window
Ensure trace A is active and  If not, click Display > Active Trace > Active A 
shows the spectrum display Then click Trace > Data > Spectrum
Change the trigger to Free Run Click Input > Playback Trigger 
 Select Free Run in Type drop-down menu
Set the time length to 100 nsec Click MeasSetup > Time 
 Type 100 nsec in the Main Time Length field
Set Max Overlap to 95% Click MeasSetup > Time 
 Type 95% in the Max Overlap (Avg Off) field
Enable the spectrogram display Right-click trace A 
 Select Show Spectrogram 
 Note: You may need to adjust the scale by  
 auto-scaling the trace or by adjusting the  
 parameters on the Trace > Y Scale menu .
Once finished with the spectrogram  Right-click trace A 
measurement, disable it Clear Show Spectrogram

Figure 8. Spectrogram display of a non-hopped MB-OFDM signal. Notice the slight 
splatter at the beginning and end of each symbol.
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Self-Guided Demonstration (continued)
Spectrum and time domain measurements

Figure 9 is an example spectrogram of 
a hopped signal that uses TFC 1 . The 
vertical color bar on the left side of the 
spectrogram trace shows the color 
assignment for signal power . The 
highest power is red . This display 
allows the user to quickly identify 
spectral problems such as out of band 
spur and splatter that may occur at 
symbol transition points when the 
signal hops from one center frequency 
to another .

Figure 9. Spectrum of an MB-OFDM signal hopped over three center 
frequencies.
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Self-Guided Demonstration (continued)
Basic digital demodulation

Once the RF and timing parameters 
have been investigated as described 
above, basic signal demodulation may 
begin . The MB-OFDM demodulator’s 
settings are controlled using the 
demodulator properties .

1 Spectrum and time domain measurements
Get basics right, find major problems

2 Basic digital demodulation
Signal quality numbers, constellation, basic error vector measurement

3 Advanced digital demodulation
Find specific problems and causes

Table 10. Turning on the demodulator and viewing the demodulator properties
Instructions Navigation
View a stacked 2 display Click Display > Layout > Stacked 2
Open the demodulator Click MeasSetup > Demodulator >  
 Ultra-Wideband > MB-OFDM
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Self-Guided Demonstration (continued)
Basic digital demodulation

The default demod properties must be 
changed in order to properly demodulate 
the signal that was recalled in this 
example . The data rate of this signal is 
480 Mb/s – this value can be changed 
in the drop-down menu . The recorded 
signal used here has a standard PLCP 
preamble, not a burst preamble . It uses 
Time Frequency Code (TFC) 6, so this 
needs to be set . Because this signal 
uses TFC 6, it is not, in fact, frequency-
hopped . Therefore, frequency hopping 
analysis is automatically disabled . 
Otherwise, if the signal being tested 
used a different TFC, but was not 
actually hopped, frequency hopping 
analysis would have to be disabled . 
This is useful when troubleshooting 
a system, particularly in the early 
development phases, as designers can 
verify all parameters prior to actually 
hopping the signal . After performing 
these steps, the signal will be 
demodulated properly . The first 
indication of this will be the proper 
constellations in trace A .

Figure 10 shows the OFDM composite 
error summary in the bottom display . 
To view this, simply change the bottom 
display to show trace D .

Table 11. Selecting the correct data rate and TFC
Instructions Navigation
Select TFC 6 and data rate Click MeasSetup > DemodProperties  
 On Format tab select Preset to Standard > Band  
 group 1 > TFC 6 ch 14 
 Select Data Rate > 480 Mb/s
Show the error summary table Click Display > Active Trace > Active B 
 Or, click trace B title (hot-spot) 
 Select Channel 1 Comp > Errs

Figure 10. Basic demodulation of UWB signal showing constellations with header,
payload, and pilots plus error summary table.

Table 12. Viewing the OFDM composite error summary in the bottom display
Instructions Navigation
Change the bottom display to show  Click trace B 
the OFDM composite error summary On the toolbar, click D
Return bottom trace to spectrum Click trace D (bottom) 
 On the toolbar, click B 
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Self-Guided Demonstration (continued)
Basic digital demodulation

The OFDM composite error summary 
display shows modulation quality 
metrics such as Error Vector Magnitude 
(EVM) or Relative Constellation Error 
(RCE) . This number summarizes the 
modulation quality of the signal over 
the measurement time (also called the 
measurement interval) . Other metrics, 
such as the common pilot error (CPE) 
and IQ offset are also shown .

The flexibility of the 89600 VSA 
software allows the user to view 
multiple result displays simultaneously . 
This will show a screen with the 
following traces, clockwise from the 
upper-left display: the constellation, 
OFDM error vector spectrum, OFDM 
composite error summary displays, and 
spectrum . On any display with a trace, 
the user may right-click the display and 
select Y Auto Scale to automatically  
scale for proper viewing of the entire 
result .

Closer examination of the constellation 
will reveal the color-coded constellation 
points that are part of the display . For 
the MB-OFDM signal, data points are 
shown in red, and pilot points are 
shown in white (using the default 
display appearance colors which are 
different than those shown here) . The 
blue points correspond to the points 
from the 10 guard subcarriers that 
are on either side of the signal in the 
frequency domain . This same color-
coding scheme applies to the other 
displays as well, for example, in the 
error vector spectrum display .

Table 13. Viewing four displays simultaneously
Instructions Navigation
Set the layout of the displays to show  Click Display > Layout > Grid 2x2 or  
four displays in a 2x2 grid format select Grid 2x2 from the drop-down menu in the  
 tool bar (currently displaying Stacked 2)

Figure 11. 2x2 configuration showing constellation, error vector spectrum, 
spectrum, and error summary displays.
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Self-Guided Demonstration (continued)
Basic digital demodulation

The spectrum mask measurement 
ensures that the power level of the 
UWB signal is within limits and 
compliant to regulatory standards . A 
swept-tuned spectrum analyzer could 
be used to make this measurement, 
but the 89600 VSA can perform the 
same measurement and eliminates the 
need to set up a spectrum analyzer .

The error vector spectrum display 
shows the spectrum of the error vector 
as a function of time (error vector time 
display) . Viewing the error vector 
spectrum can give added insight into 
the nature and origin of these error 
signals . Notice in this display there are 
white points, which correspond to pilot 
symbols, and a solid line that runs 
horizontally through the trace . This line 
is the rms average of the EVM spectrum 
across the frequency axis shown . 

The error vector spectrum display shows  
the EVM (also relative constellation 
error or RCE) by carrier . The white 
carriers are the pilot tones and the 
blue carriers are the guard tones . Each 
dot on a carrier is the EVM (RCE) of 
that carrier for a particular symbol time .

Table 14. Enabling the spectral mask measurement
Instructions Navigation
Ensure the spectrum display is  Click Display > Active Trace > Active B  
the active trace Note: In this case Trace B is the spectrum display .
Change the display to  Click Trace > Data > Ch 1 Comp >  
packet spectrum Packet Spectrum
Recall the limit tests Click Utilities > Limit Tests > Recall 
 Navigate to the Limits directory: (C:\Program  
 Files\Agilent\89600 VSA\Examples\Limits) 
 Load the file “WiMediaPSDMaskHigh .lims,”  
 and do the same for the files  
 “WiMediaPSDMaskMid .lims” and  
 “WiMediaPSDMaskLow .lims” 
 Click Close
Open the limits menu Click Markers > Limits
Enable the spectral mask limit lines Select the Limit Test check box 
 Select “WiMediaPSDMaskMid” from the Name  
 drop-down menu 
 Note: We are using this limit test because our  
 signal only occupies the Mid-band, however, if  
 you had a hopping signal, you could make  
 measurements on any of the bands .
Once finished with the measurement,  Click Markers > Limits 
turn off the limit lines Clear the Limit Test check box

Figure 12. Spectrum mask measurement performed over the packet spectrum 
trace.
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Self-Guided Demonstration
Advanced digital demodulation

1 Spectrum and time domain measurements
Get basics right, find major problems

2 Basic digital demodulation
Signal quality numbers, constellation, basic error vector measurement

3 Advanced digital demodulation
Find specific problems and causes

More advanced troubleshooting and 
investigation into signal characteristics 
and signal quality can be made by 
viewing other displays . Two additional 
displays will then be shown – in this 
case the search time and OFDM 
common pilot error displays . 

Table 15. Viewing six displays simultaneously
Instructions Navigation
Set the layout of the displays to show  Click Display > Layout > Grid 2x3 
six displays in a 2x3 grid format
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Any of these displays can be changed 
to show a different trace or result . For 
example, you can change trace B to 
show error vector time . The error vector 
time display is similar to the EVM 
spectrum display, except that it 
displays EVM (RCE) using the time-
domain as the reference axis, so that 
the progression of errors over time 
(symbols) can be seen . 

Table 16. Showing the error vector time display
Instructions Navigation
Make trace B the active trace Click Display > Active Trace > Active B
Change trace B to show  Click Trace > Data >Chan 1 Comp >  
error vector time Error Vector Time

Self-Guided Demonstration (continued)
Advanced digital demodulation

Figure 13. 2x3 configuration allows the user to view multiple results and traces 
simultaneously.
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Self-Guided Demonstration (continued)
Advanced digital demodulation

Markers are mandatory for accurate 
measurement of specific points in the 
time, frequency, and modulation traces . 
Markers can be displayed on individual 
traces by selecting the marker icon in 
the toolbar, and then left-clicking a 
display, or by right-clicking a display 
and selecting Show Marker . 
Additional markers can be placed on 
other displays at the same time .

Coupled markers can be used to identify 
errors and then pinpoint their precise 
location from different perspectives, in 
order to more quickly and accurately 
find their source . The bottom of the 
window will report the marker readout 
of the first marker placed, as well as 
the readout from the markers in the 
other displays .

Table 17. Enabling multiple, coupled markers
Instructions Navigation
Place a marker in the OFDM RMS  Right-click trace B (OFDM RMS Err Vect Time)  
Error Vector Time display Select Show Marker
Enable markers on the other displays Click Markers > Couple Markers 
  . . .this will place markers in the other displays and  
 couple them 
 Note: You can experiment with this function by  
 selecting the constellation display (or other) and  
 using the right arrow key –> to move the marker   
 to its next position . Clear markers by selecting  
 each trace with a right-click and clearing 
 Show Marker or by going to the menu and 
 clicking on Markers >Show Marker to toggle 
 the markers off .

A very useful display for MB-OFDM 
signals is the preamble phase error 
display . This result shows the error 
present in the phase of the preamble, 
which is used for timing synchronization 
and channel estimation . Problems in 
the preamble will generally result in 
poor sync correlation .

Table 18. View the preamble phase error display
Instructions Navigation
Change trace E to show the preamble  Double-click the Trace Data hot-spot located on  
phase error display the title of the display, E: Ch1 Search Time 
 Select Channel 1 Comp in the Type (left column)  
 dialog box 
 Select Preamble Phase Err in the Data (right  
 column) dialog box 
 Click OK to accept
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Self-Guided Demonstration (continued)
Advanced digital demodulation

MB-OFDM signals at 480 Mb/s use 
DCM modulation in the payload . This 
portion of the signal can be analyzed 
simply by setting the measurement 
interval and offset appropriately .

These two parameters can be adjusted 
to show measurement points anywhere 
within the maximum result length 
measured .

In this instance, we will delay the start of 
the measurement for 12 symbol-times to 
avoid measuring the QPSK header . By 
decreasing the number of symbol-times 
you look at, you can perform more 
detailed analysis if needed .

Additional advanced 
analysis

The 89600 VSA software offers 
additional advanced displays and 
measurements . Essentially, it can act 
as a receiver allowing measurement 
of HCS and RS errors along with actual 
decode and checking of FCS . Change 
your measurement data type to 
Composite Header Info/Data and 
OFDM Composite PSDU Info/Data 
and check the Help text for more 
information .

Table 19. Analyze DCM modulation
Instructions Navigation
Change the measurement interval Click MeasSetup > Demod Properties 
 Select Time tab
 On the Time Tab, type 24 symbol-times in the  
 measurement interval field
Change the offset to view the DCM  Type 12 symbol-times for Measurement Offset 
modulated portion of the signal

Figure 14. Demodulation of dual-carrier modulated UWB signal (Note: 
constellation in upper left).
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Summary

The complexities and challenges 
inherent in MB-OFDM signals are not 
trivial . Low power, very high data rates, 
high carrier frequencies, short symbol 
times, frequency hopping patterns, and 
other properties all increase the need for 
an advanced tool that can troubleshoot 
and determine the root cause among 
many possibilities . The Agilent 89600 
VSA software with Multiband-OFDM 

modulation analysis dissects signals in 
powerful ways that help designers and 
developers get their product to market 
quickly . Its available presets, multiple-
results screen, coupled markers, and 
specific displays such as preamble phase 
error allow the user to concentrate on 
the signal under test, and not the test 
equipment itself . 
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Timing Diagram

PreA Hdr Payload

PreA Hdr PayloadHdr Payload PreA

Maximum TRIGGERED Result Length
(Includes Header, p/o Payload)

Maximum Packet Length for Triggered mode

Trigger

Maximum SEARCH Length
(Includes Preamble, Header, p/o Payload)

Maximum PULSE SEARCH Results Length
(Includes Header and 96/48 Sym Payload)

Maximum SEARCH Length

Maximum Packet Length for PULSE SEARCH

Triggered measurement:
 Packet may be > maximum search length
 Result length limited to maximum results length

PreA Hdr Payload

PreA Hdr PayloadHdr Payload PreA

Maximum TRIGGERED Result Length
(Includes Header, p/o Payload)

Maximum Packet Length for Triggered mode

Trigger

Maximum SEARCH Length
(Includes Preamble, Header, p/o Payload)

Maximum PULSE SEARCH Results Length
(Includes Header and 96/48 Sym Payload)

Maximum SEARCH Length

Maximum Packet Length for PULSE SEARCH

Pulse search measurement:
 Packet time must be < 0.5 * (maximum search length – 1.875 µs)
 Payload limited to 96 or 48 symbols (see table)

Figure 14. Timing diagram showing the relationship between triggered and pulse search measurements with 
respect to frame structure.
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Glossary

CPE  Common Pilot Error

DCM  Dual Carrier Modulation

DS-UWB  Direct-Sequence Ultra Wideband

EVM  Error Vector Magnitude

FFT  Fast Fourier Transform

IFFT  Inverse Fast Fourier Transform

MAC  Media Access Control

MBOA  Multiband OFDM

MB-OFDM  Multi-band Orthogonal Frequency Division Multiplexing

MIFS  Minimum Inter-Frame Separation

OBW  Occupied Bandwidth

PDSU  PHY Service Data Unit

PHY  Physical

PLCP  Physical Layer Convergence Protocol

QPSK  Quadrature Phase Shift Keying

RCE  Relative Constellation Error

TFC  Time-Frequency Code

TFC  Time-Frequency Codes

UWB  Ultra Wideband

WPAN  Wireless Personal Area Network

ZPS  Zero-padded Suffix
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